aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ptpd
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-04-04 12:05:22 -0700
committerTom Rini <tom_rini@mentor.com>2011-04-04 12:05:22 -0700
commitde42055b9a53b36b0dbb714cc639b918de02ff75 (patch)
tree61ce3662a2f398d8d5a48dab7af19e7af8e65f7b /recipes/ptpd
parent9a888d16d8bc12e41b2d18b1f9d1ba80fdd7f2c6 (diff)
downloadopenembedded-de42055b9a53b36b0dbb714cc639b918de02ff75.tar.gz
ptpd: Add a patch to bring in limits.h
Taken from the old bugzilla: http://lists.linuxtogo.org/pipermail/openembedded-commits/2010-January/041030.html Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/ptpd')
-rw-r--r--recipes/ptpd/ptpd-1.0.0/add-limit-h.patch26
-rw-r--r--recipes/ptpd/ptpd_1.0.0.bb6
2 files changed, 30 insertions, 2 deletions
diff --git a/recipes/ptpd/ptpd-1.0.0/add-limit-h.patch b/recipes/ptpd/ptpd-1.0.0/add-limit-h.patch
new file mode 100644
index 0000000000..8ed3f2f977
--- /dev/null
+++ b/recipes/ptpd/ptpd-1.0.0/add-limit-h.patch
@@ -0,0 +1,26 @@
+ptpd: fix ftbfs by including limits.h so MAX_INT defined
+
+The current recipe for ptpd fails to build with:
+
+| arith.c: In function 'fromInternalTime':
+| arith.c:46: error: 'INT_MAX' undeclared (first use in this function)
+| arith.c:46: error: (Each undeclared identifier is reported only once
+| arith.c:46: error: for each function it appears in.)
+| arith.c: In function 'toInternalTime':
+| arith.c:64: error: 'INT_MAX' undeclared (first use in this function)
+| make: *** [arith.o] Error 1
+| make: *** Waiting for unfinished jobs....
+| FATAL: oe_runmake failed
+
+diff --git a/src/arith.c b/src/arith.c
+--- a/src/arith.c
++++ b/src/arith.c
+@@ -1,6 +1,7 @@
+ /* arith.c */
+
+ #include "ptpd.h"
++#include <limits.h>
+
+ /* from annex C of the spec */
+ UInteger32 crc_algorithm(Octet *buf, Integer16 length)
+
diff --git a/recipes/ptpd/ptpd_1.0.0.bb b/recipes/ptpd/ptpd_1.0.0.bb
index 656430ecb2..a650d11d49 100644
--- a/recipes/ptpd/ptpd_1.0.0.bb
+++ b/recipes/ptpd/ptpd_1.0.0.bb
@@ -2,9 +2,11 @@ DESCRIPTION = "Precision Time Protocol (PTP) as defined by the IEEE 1588 standar
HOMEPAGE = "http://sourceforge.net/projects/ptpd"
LICENSE = "BSD"
SECTION = "network"
-PR = "r0"
+PR = "r1"
+
+SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${PV}/ptpd-${PV}.tar.gz \
+ file://add-limit-h.patch;striplevel=2"
-SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${PV}/ptpd-${PV}.tar.gz"
S = "${WORKDIR}/ptpd-${PV}/src"
do_install() {