aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/putty/putty_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/putty/putty_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/putty/putty_svn.bb')
-rw-r--r--recipes/putty/putty_svn.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/putty/putty_svn.bb b/recipes/putty/putty_svn.bb
new file mode 100644
index 0000000000..c96ffbb213
--- /dev/null
+++ b/recipes/putty/putty_svn.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "PuTTY is a free implementation of Telnet and SSH for Win32 and Unix platforms"
+SECTION = "console/network"
+LICENSE = "MIT"
+#Remove the dash below when 0.58 changes in PV
+PV = "0.58+cvs-${SRCDATE}"
+
+SRC_URI = "svn://ixion.tartarus.org/main;module=putty \
+ file://lib.pro \
+ file://plink.pro \
+ file://pscp.pro \
+ file://psftp.pro"
+
+TARGETS = "lib plink pscp psftp"
+
+S = "${WORKDIR}/putty"
+
+inherit qmake_base
+
+do_configure() {
+ for t in ${TARGETS}
+ do
+ install -m 0644 ${WORKDIR}/$t.pro .
+ done
+ cd charset && perl sbcsgen.pl
+}
+
+do_compile() {
+ for t in ${TARGETS}
+ do
+ rm -f Makefile
+ qmake -makefile -o Makefile -spec ${QMAKESPEC} $t.pro
+ oe_runmake
+ done
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ oe_libinstall -so libputty ${D}${libdir}
+ install -d ${D}${bindir}/
+ install -m 0755 plink ${D}${bindir}/ssh
+ install -m 0755 pscp ${D}${bindir}/scp
+ install -m 0755 psftp ${D}${bindir}/sftp
+}
+