aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/puzz-le
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/puzz-le
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/puzz-le')
-rw-r--r--recipes/puzz-le/puzz-le-2.0.0/gcc3.patch24
-rw-r--r--recipes/puzz-le/puzz-le_2.0.0.bb18
2 files changed, 42 insertions, 0 deletions
diff --git a/recipes/puzz-le/puzz-le-2.0.0/gcc3.patch b/recipes/puzz-le/puzz-le-2.0.0/gcc3.patch
new file mode 100644
index 0000000000..9435dc5c95
--- /dev/null
+++ b/recipes/puzz-le/puzz-le-2.0.0/gcc3.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- puzzle_arm/OptionsDialog.cpp~gcc3 2002-07-16 04:01:12.000000000 +0200
++++ puzzle_arm/OptionsDialog.cpp 2004-02-19 21:10:32.000000000 +0100
+@@ -24,14 +24,14 @@
+
+ int OptionsDialog::sOptions[5]={60,50,40,30,20};
+
+-OptionsDialog::OptionsDialog(QString *currLevel,QString *th, bool *se,bool *ar,bool *tl, int *gs, QWidget *parent=0,const char *name=0):QDialog(parent,name,true,WStyle_Customize|WStyle_NoBorderEx )
++OptionsDialog::OptionsDialog(QString *currLevel,QString *th, bool *se,bool *ar,bool *tlx, int *gs, QWidget *parent,const char *name):QDialog(parent,name,true,WStyle_Customize|WStyle_NoBorderEx )
+ {
+ the=th;
+ ile=currLevel;
+ ise=se;
+ iar=ar;
+ igs=gs;
+- itl=tl;
++ itl=tlx;
+
+ QFont f=font();
+ f.setBold(true);
diff --git a/recipes/puzz-le/puzz-le_2.0.0.bb b/recipes/puzz-le/puzz-le_2.0.0.bb
new file mode 100644
index 0000000000..01caafe650
--- /dev/null
+++ b/recipes/puzz-le/puzz-le_2.0.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Puzz-le is a colorful arcade logic game for Qt/Embedded based Palmtop Environments."
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+PR = "r1"
+
+SRC_URI = "http://www.warmi.net/zaurus/files/puzz-le_${PV}.tar.gz \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/puzzle_arm"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin
+ install -m 0755 puzz-le ${D}${palmtopdir}/bin/
+ cp -pPR Qtopia/puzz-le/opt/QtPalmtop/* ${D}${palmtopdir}/
+}