aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pwlib/pwlib_1.5.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pwlib/pwlib_1.5.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pwlib/pwlib_1.5.2.bb')
-rw-r--r--recipes/pwlib/pwlib_1.5.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/pwlib/pwlib_1.5.2.bb b/recipes/pwlib/pwlib_1.5.2.bb
new file mode 100644
index 0000000000..a4ced1f35c
--- /dev/null
+++ b/recipes/pwlib/pwlib_1.5.2.bb
@@ -0,0 +1,32 @@
+# pwlib .bb build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+HOMEPAGE="http://www.openh323.org/docs/PWLib/"
+DESCRIPTION="Portable Text and GUI C/C++ Class Libarary."
+LICENSE = "GPL"
+
+SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
+DEPENDS="openssl openldap"
+
+inherit autotools
+
+EXTRA_OECONF="--enable-ipv6 --disable-sasl --disable-sdl \
+ --disable-video --enable-plugins --with-plugins=oss"
+
+S="${WORKDIR}/${PN}"
+
+# Use openSSL
+
+export OPENSSLFLAG="1"
+export OPENSSLDIR="${STAGING_LIBDIR}"
+export OPENSSLLIBS="-lssl -lcrypt"
+export MACHTYPE="x86"
+export OSTYPE="linux"
+export OSRELEASE="openembedded"
+
+export CPLUS="${CXX}"
+
+do_compile() {
+ oe_runmake opt
+}