aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pyside
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-05-01 19:34:38 +0200
committerSimon Busch <morphis@gravedo.de>2011-05-10 23:45:52 +0200
commit2d3fd2a73bd18af203b79cf0a9011d04a5f99796 (patch)
tree5498cc639fc4b98fe297c8fbd684a4132627e42e /recipes/pyside
parentd5e59ef9e7c7a117aba2f3ddd65d48fce85c7b25 (diff)
downloadopenembedded-2d3fd2a73bd18af203b79cf0a9011d04a5f99796.tar.gz
apiextractor-native: add initial recipe to build the native version
The apiexractor is needed to build the python pyside binding for Qt. Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes/pyside')
-rw-r--r--recipes/pyside/apiextractor-native_0.10.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/pyside/apiextractor-native_0.10.2.bb b/recipes/pyside/apiextractor-native_0.10.2.bb
new file mode 100644
index 0000000000..6ec70728ab
--- /dev/null
+++ b/recipes/pyside/apiextractor-native_0.10.2.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "API Extractor is a tool that eases the development of bindings \
+of Qt-based libraries for high level languages by automating most of the process."
+HOMEPAGE = "http://www.pyside.org"
+LICENSE = "LGPL"
+DEPENDS = "qt4-native"
+PR = "r0"
+
+SRC_URI = "http://www.pyside.org/files/apiextractor-${PV}.tar.bz2"
+S = "${WORKDIR}/apiextractor-${PV}"
+
+SRC_URI[md5sum] = "946e8988e5f4c4bd62e774407fa80fee"
+SRC_URI[sha256sum] = "82c6c24dc55458ed047eba9fe700894a3347cd53462b21a97b7b5f9180b2a896"
+
+inherit cmake native
+