aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pyside
diff options
context:
space:
mode:
authorSimon Busch <morphis@gravedo.de>2011-05-13 08:59:46 +0200
committerSimon Busch <morphis@gravedo.de>2011-05-13 09:05:05 +0200
commita02f8a6711952fc276e86ef7ce3c826bde5f5d01 (patch)
treef37eb81fa1bc5b971e1782f7e0e33a910cc1df99 /recipes/pyside
parent54ab33ecea4d870a119ddb0aabbbd2b57c98b253 (diff)
downloadopenembedded-a02f8a6711952fc276e86ef7ce3c826bde5f5d01.tar.gz
python-pyside-embedded: extend support for the QWS system
By default pyside does not support the relevant parts for QWS of Qt. For this we added a patch within OE which makes some QWS classes available with pyside. Signed-off-by: Simon Busch <morphis@gravedo.de>
Diffstat (limited to 'recipes/pyside')
-rw-r--r--recipes/pyside/python-pyside-embedded/support-qws.patch7
-rw-r--r--recipes/pyside/python-pyside-embedded_1.0.2.bb2
2 files changed, 5 insertions, 4 deletions
diff --git a/recipes/pyside/python-pyside-embedded/support-qws.patch b/recipes/pyside/python-pyside-embedded/support-qws.patch
index fed126f3fb..299109a38b 100644
--- a/recipes/pyside/python-pyside-embedded/support-qws.patch
+++ b/recipes/pyside/python-pyside-embedded/support-qws.patch
@@ -1,6 +1,6 @@
diff -Naur pyside-qt4.7+1.0.2-orig/CMakeLists.txt pyside-qt4.7+1.0.2/CMakeLists.txt
--- pyside-qt4.7+1.0.2-orig/CMakeLists.txt 2011-04-28 22:43:01.000000000 +0200
-+++ pyside-qt4.7+1.0.2/CMakeLists.txt 2011-05-01 19:01:11.824051001 +0200
++++ pyside-qt4.7+1.0.2/CMakeLists.txt 2011-05-11 11:21:17.826916001 +0200
@@ -105,6 +105,8 @@
elseif(Q_WS_SIMULATOR)
set(ENABLE_SIMULATOR "1")
@@ -12,8 +12,8 @@ diff -Naur pyside-qt4.7+1.0.2-orig/CMakeLists.txt pyside-qt4.7+1.0.2/CMakeLists.
endif()
diff -Naur pyside-qt4.7+1.0.2-orig/PySide/QtGui/typesystem_gui_qws.xml pyside-qt4.7+1.0.2/PySide/QtGui/typesystem_gui_qws.xml
--- pyside-qt4.7+1.0.2-orig/PySide/QtGui/typesystem_gui_qws.xml 1970-01-01 01:00:00.000000000 +0100
-+++ pyside-qt4.7+1.0.2/PySide/QtGui/typesystem_gui_qws.xml 2011-05-01 19:01:27.544051001 +0200
-@@ -0,0 +1,22 @@
++++ pyside-qt4.7+1.0.2/PySide/QtGui/typesystem_gui_qws.xml 2011-05-11 11:22:45.246916001 +0200
+@@ -0,0 +1,23 @@
+<?xml version="1.0"?>
+<!--
+ This file is part of PySide project.
@@ -35,4 +35,5 @@ diff -Naur pyside-qt4.7+1.0.2-orig/PySide/QtGui/typesystem_gui_qws.xml pyside-qt
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+-->
+<typesystem package="PySide.QtGui">
++ <object-type name="QWSServer"/>
+</typesystem>
diff --git a/recipes/pyside/python-pyside-embedded_1.0.2.bb b/recipes/pyside/python-pyside-embedded_1.0.2.bb
index 865d0b0dc0..97875e2ce9 100644
--- a/recipes/pyside/python-pyside-embedded_1.0.2.bb
+++ b/recipes/pyside/python-pyside-embedded_1.0.2.bb
@@ -1,6 +1,6 @@
require python-pyside.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += " \
file://no-accessibility-support.patch \
file://support-qws.patch \