aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pythm
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:27:22 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:49 +0100
commit09e1c75d958bd47f128389001b36567e8263bfe8 (patch)
tree26bb9a05bd150f2f5c5e4d0a28691886d7e619d5 /recipes/pythm
parentaf81d9fd5f8a4dc8c65607cd4a92e9db19db2b12 (diff)
downloadopenembedded-09e1c75d958bd47f128389001b36567e8263bfe8.tar.gz
pythm: new recipe from SHR
Diffstat (limited to 'recipes/pythm')
-rw-r--r--recipes/pythm/pythm/mplayer-escape-filenames.patch19
-rw-r--r--recipes/pythm/pythm/pythm.conf32
-rw-r--r--recipes/pythm/pythm/pythm.desktop12
-rw-r--r--recipes/pythm/pythm_svn.bb36
4 files changed, 99 insertions, 0 deletions
diff --git a/recipes/pythm/pythm/mplayer-escape-filenames.patch b/recipes/pythm/pythm/mplayer-escape-filenames.patch
new file mode 100644
index 0000000000..329f4ef7f4
--- /dev/null
+++ b/recipes/pythm/pythm/mplayer-escape-filenames.patch
@@ -0,0 +1,19 @@
+diff -ur pythm-org/pythm/mplayer/mplayerbackend.py pythm/pythm/mplayer/mplayerbackend.py
+--- pythm-org/pythm/mplayer/mplayerbackend.py 2008-11-22 14:18:13.227163500 +0100
++++ pythm/pythm/mplayer/mplayerbackend.py 2009-01-15 23:54:50.582429054 +0100
+@@ -96,7 +96,7 @@
+ entry = self.current[1]
+ self.emit(Signals.SONG_CHANGED,entry)
+ self.songend = time.time()
+- fn = entry.id
++ fn = re.escape(entry.id)
+ array = self.mplayer.innercmd("loadfile '" + fn + "'\n","======",True)
+ #array = self.mplayer.arraycmd("loadfile","======",fn)
+ self.fill_entry(array, entry)
+@@ -404,4 +404,4 @@
+ self.browse()
+
+
+-
+\ Kein Zeilenumbruch am Dateiende.
++
diff --git a/recipes/pythm/pythm/pythm.conf b/recipes/pythm/pythm/pythm.conf
new file mode 100644
index 0000000000..2fbe3c4997
--- /dev/null
+++ b/recipes/pythm/pythm/pythm.conf
@@ -0,0 +1,32 @@
+# global pythm settings
+# place this file in ~/.pythm/, name it pythm.conf
+
+[pythm]
+# backends to show in backend list
+backends=mpd,mplayer
+# the default backend to use, can be either
+# mpd or mplayer, or omitted
+backend=mplayer
+
+# mpd specific settings
+[mpd]
+# mpd host
+host=localhost
+# mpd port
+port=6600
+# mpd password, comment out for no password
+#password=verysecret
+
+# mplayer settings
+[mplayer]
+# renice val for mplayer process
+renice=-15
+
+# directory containing music (the start folder for the browser)
+musicdir=~
+# allowed file endings in browse mode, comma separated
+endings=ogg,mp3
+# filters to exclude in file browser. applied to files and directories
+# using regular expressions. use filtersN for more entries
+# default is to ignore all elements that start with a ".".
+filters0=\..*
diff --git a/recipes/pythm/pythm/pythm.desktop b/recipes/pythm/pythm/pythm.desktop
new file mode 100644
index 0000000000..89f74d50bb
--- /dev/null
+++ b/recipes/pythm/pythm/pythm.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=0.5
+Type=Application
+Encoding=UTF-8
+Name=pythm
+Comment=pyGTK+ Frontend for MPD and mplayer
+TryExec=pythm-bin
+Exec=pythm-bin
+Icon=bass.png
+Categories=Application;AudioVideo;Audio;Player;
+Categories=Office;
+Terminal=false
diff --git a/recipes/pythm/pythm_svn.bb b/recipes/pythm/pythm_svn.bb
new file mode 100644
index 0000000000..fdffb21621
--- /dev/null
+++ b/recipes/pythm/pythm_svn.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Pythm is a media player gui designed to work with mplayer or mpd as "slave" players.\
+use mplayer to hear music on the road or mpd control if your are at home."
+HOMEPAGE = "http://projects.openmoko.org/projects/pythm/"
+SECTION = "application/multimedia"
+LICENSE = "GPLv2"
+SRCNAME = "pythm"
+PV = "0.5.1+svnr${SRCPV}"
+PR = "r3"
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=pythm \
+ file://mplayer-escape-filenames.patch;patch=0 \
+ file://pythm.desktop \
+ file://pythm.conf"
+S = "${WORKDIR}/pythm"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-pygtk \
+ mplayer \
+"
+DISTUTILS_INSTALL_ARGS = "--root=${D} \
+ --prefix=${prefix} \
+ --install-data=${datadir}"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -d ${D}/${datadir}/applications
+ install -m 0644 ../pythm.conf ${D}${sysconfdir}
+ install -m 0644 ../pythm.desktop ${D}/${datadir}/applications
+}
+
+
+FILES_${PN} += "\
+ ${sysconfdir}/pythm.conf \
+ ${datadir}/applications/pythm.desktop"
+