aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-imaging_1.1.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-imaging_1.1.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-imaging_1.1.6.bb')
-rw-r--r--recipes/python/python-imaging_1.1.6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/python/python-imaging_1.1.6.bb b/recipes/python/python-imaging_1.1.6.bb
new file mode 100644
index 0000000000..03e0330e1c
--- /dev/null
+++ b/recipes/python/python-imaging_1.1.6.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Python Imaging Library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "freetype jpeg tiff"
+RDEPENDS = "python-lang python-stringold"
+SRCNAME = "Imaging"
+PR = "ml1"
+
+SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
+ file://path.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_compile() {
+ export STAGING_LIBDIR=${STAGING_LIBDIR}
+ export STAGING_INCDIR=${STAGING_INCDIR}
+ distutils_do_compile
+}
+
+do_install() {
+ export STAGING_LIBDIR=${STAGING_LIBDIR}
+ export STAGING_INCDIR=${STAGING_INCDIR}
+ distutils_do_install
+ install -d ${D}${datadir}/doc/${PN}/html/
+ install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
+
+}