summaryrefslogtreecommitdiffstats
path: root/recipes/python/python-mad_0.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-mad_0.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-mad_0.6.bb')
-rw-r--r--recipes/python/python-mad_0.6.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/python/python-mad_0.6.bb b/recipes/python/python-mad_0.6.bb
new file mode 100644
index 0000000000..7ae43779e9
--- /dev/null
+++ b/recipes/python/python-mad_0.6.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Python libmad Bindings"
+SECTION = "devel/python"
+HOMEPAGE = "http://spacepants.org/src/pymad/"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "libmad"
+SRCNAME = "pymad"
+PR = "ml1"
+
+SRC_URI = "http://spacepants.org/src/pymad/download/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ touch Setup
+ echo "endian = little" >>Setup # FIXME, not always true
+ echo "mad_libs = mad" >>Setup
+ echo "mad_lib_dir = ${STAGING_LIBDIR}" >>Setup
+ echo "mad_include_dir = ${STAGING_INCDIR}" >>Setup
+}