aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-native-2.6.1
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-14 13:25:03 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-14 13:25:03 +0100
commita4bddfe9e6a513a8ad1881ed2ffd419390cf20e7 (patch)
treec69d4cd238d15f819195eb06428fb61219d6f37b /recipes/python/python-native-2.6.1
parente0d271c7fde73ff1fe2a037d8b8a84b1395eadc1 (diff)
downloadopenembedded-a4bddfe9e6a513a8ad1881ed2ffd419390cf20e7.tar.gz
python-native: do not look in host paths for shared objects
Diffstat (limited to 'recipes/python/python-native-2.6.1')
-rw-r--r--recipes/python/python-native-2.6.1/debug.patch27
-rw-r--r--recipes/python/python-native-2.6.1/nohostlibs.patch53
2 files changed, 80 insertions, 0 deletions
diff --git a/recipes/python/python-native-2.6.1/debug.patch b/recipes/python/python-native-2.6.1/debug.patch
new file mode 100644
index 0000000000..beb3adc6db
--- /dev/null
+++ b/recipes/python/python-native-2.6.1/debug.patch
@@ -0,0 +1,27 @@
+Index: Python-2.6.1/Lib/distutils/unixccompiler.py
+===================================================================
+--- Python-2.6.1.orig/Lib/distutils/unixccompiler.py 2009-11-13 16:04:54.000000000 +0000
++++ Python-2.6.1/Lib/distutils/unixccompiler.py 2009-11-13 16:06:27.000000000 +0000
+@@ -300,6 +300,8 @@
+ dylib_f = self.library_filename(lib, lib_type='dylib')
+ static_f = self.library_filename(lib, lib_type='static')
+
++ print "Looking in %s for %s" % (lib, dirs)
++
+ for dir in dirs:
+ shared = os.path.join(dir, shared_f)
+ dylib = os.path.join(dir, dylib_f)
+@@ -309,10 +311,13 @@
+ # assuming that *all* Unix C compilers do. And of course I'm
+ # ignoring even GCC's "-static" option. So sue me.
+ if os.path.exists(dylib):
++ print "Found %s" % (dylib)
+ return dylib
+ elif os.path.exists(shared):
++ print "Found %s" % (shared)
+ return shared
+ elif os.path.exists(static):
++ print "Found %s" % (static)
+ return static
+
+ # Oops, didn't find it in *any* of 'dirs'
diff --git a/recipes/python/python-native-2.6.1/nohostlibs.patch b/recipes/python/python-native-2.6.1/nohostlibs.patch
new file mode 100644
index 0000000000..7020f3c2a9
--- /dev/null
+++ b/recipes/python/python-native-2.6.1/nohostlibs.patch
@@ -0,0 +1,53 @@
+Index: Python-2.6.1/setup.py
+===================================================================
+--- Python-2.6.1.orig/setup.py 2009-11-13 16:20:47.000000000 +0000
++++ Python-2.6.1/setup.py 2009-11-13 16:28:00.000000000 +0000
+@@ -310,8 +310,8 @@
+
+ def detect_modules(self):
+ # Ensure that /usr/local is always used
+- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
+- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
++ #add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
++ #add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+
+ # Add paths specified in the environment variables LDFLAGS and
+ # CPPFLAGS for header and library files.
+@@ -347,10 +347,10 @@
+ for directory in reversed(options.dirs):
+ add_dir_to_list(dir_list, directory)
+
+- if os.path.normpath(sys.prefix) != '/usr':
+- add_dir_to_list(self.compiler.library_dirs,
++
++ add_dir_to_list(self.compiler.library_dirs,
+ sysconfig.get_config_var("LIBDIR"))
+- add_dir_to_list(self.compiler.include_dirs,
++ add_dir_to_list(self.compiler.include_dirs,
+ sysconfig.get_config_var("INCLUDEDIR"))
+
+ try:
+@@ -361,11 +361,8 @@
+ # lib_dirs and inc_dirs are used to search for files;
+ # if a file is found in one of those directories, it can
+ # be assumed that no additional -I,-L directives are needed.
+- lib_dirs = self.compiler.library_dirs + [
+- '/lib64', '/usr/lib64',
+- '/lib', '/usr/lib',
+- ]
+- inc_dirs = self.compiler.include_dirs + ['/usr/include']
++ lib_dirs = self.compiler.library_dirs
++ inc_dirs = self.compiler.include_dirs
+ exts = []
+ missing = []
+
+@@ -583,8 +580,7 @@
+ readline_libs.append('ncurses')
+ elif self.compiler.find_library_file(lib_dirs, 'curses'):
+ readline_libs.append('curses')
+- elif self.compiler.find_library_file(lib_dirs +
+- ['/usr/lib/termcap'],
++ elif self.compiler.find_library_file(lib_dirs,
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],