aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pycups_1.9.45.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-04-24 18:34:40 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-05-20 23:15:13 -0300
commit4df5a84ef95f422d3f14423be1a098698d9838ae (patch)
tree2974350335d7efa159a634ba15d8d41889f33575 /recipes/python/python-pycups_1.9.45.bb
parentff34921286b08672277400d4d6d2678dbcb4f3c9 (diff)
downloadopenembedded-4df5a84ef95f422d3f14423be1a098698d9838ae.tar.gz
python-pycups: add
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/python/python-pycups_1.9.45.bb')
-rw-r--r--recipes/python/python-pycups_1.9.45.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/python/python-pycups_1.9.45.bb b/recipes/python/python-pycups_1.9.45.bb
new file mode 100644
index 0000000000..bd127d5559
--- /dev/null
+++ b/recipes/python/python-pycups_1.9.45.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "cups Python Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = "cups"
+SRCNAME = "pycups"
+
+SRC_URI = "http://cyberelk.net/tim/data/pycups/pycups-${PV}.tar.bz2"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+# used during compilation
+CFLAGS += -DVERSION=\\"${PV}\\"
+
+RDEPENDS = "python-core cups"