aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pydirectfb/fix-directfb-detection.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-pydirectfb/fix-directfb-detection.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-pydirectfb/fix-directfb-detection.patch')
-rw-r--r--recipes/python/python-pydirectfb/fix-directfb-detection.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/python/python-pydirectfb/fix-directfb-detection.patch b/recipes/python/python-pydirectfb/fix-directfb-detection.patch
new file mode 100644
index 0000000000..c8b7cc805a
--- /dev/null
+++ b/recipes/python/python-pydirectfb/fix-directfb-detection.patch
@@ -0,0 +1,16 @@
+Index: pydirectfb/setup.py
+===================================================================
+--- pydirectfb.orig/setup.py
++++ pydirectfb/setup.py
+@@ -11,9 +11,10 @@
+ Check dependencies add add the flags to include_dirs, library_dirs and
+ libraries. The basic logic is taken from pygame.
+ """
+- command = name + '-config --version --cflags --libs 2>/dev/null'
++ command = 'pkg-config %s --modversion --cflags --libs 2>/dev/null' % name
+ try:
+ config = os.popen(command).readlines()
++ print config
+ if len(config) == 0:
+ raise ValueError, 'command not found'
+ flags = (' '.join(config[1:]) + ' ').split()