aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pygobject_2.20.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-28 09:59:02 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-28 09:59:02 +0100
commitb4c532efcabe6dbd5ff13ae5746eb56e6594e5ba (patch)
tree7fcf7676f7862f06707e59fbfa0515633be4eb6d /recipes/python/python-pygobject_2.20.0.bb
parent1a4bd59fdadcbada295b10ff9ecc6d1b5f155ab7 (diff)
downloadopenembedded-b4c532efcabe6dbd5ff13ae5746eb56e6594e5ba.tar.gz
gnome-python: fix 2.26.1 build, add 2.28.0
python-pygobject*: add 2.20.0
Diffstat (limited to 'recipes/python/python-pygobject_2.20.0.bb')
-rw-r--r--recipes/python/python-pygobject_2.20.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/python/python-pygobject_2.20.0.bb b/recipes/python/python-pygobject_2.20.0.bb
new file mode 100644
index 0000000000..2a07a4a1a4
--- /dev/null
+++ b/recipes/python/python-pygobject_2.20.0.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Python GObject bindings"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "python-pygobject-native-${PV}"
+PE = "1"
+
+MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+SRC_URI = "\
+ ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
+ file://generate-constants.patch;patch=1 \
+"
+S = "${WORKDIR}/pygobject-${PV}"
+
+FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
+
+inherit autotools distutils-base pkgconfig
+
+# necessary to let the call for python-config succeed
+export BUILD_SYS
+export HOST_SYS
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_LIBDIR}/../share/pygobject/
+ cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
+ install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+ cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+}
+
+PACKAGES += "${PN}-lib"
+
+RDEPENDS_${PN} += "python-textutils"
+
+FILES_${PN} = "${libdir}/python*"
+FILES_${PN}-lib = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir} ${datadir}"
+FILES_${PN}-dbg += "${libdir}/.debug"