aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-scapy_2.0.0.9.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-scapy_2.0.0.9.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-scapy_2.0.0.9.bb')
-rw-r--r--recipes/python/python-scapy_2.0.0.9.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/python/python-scapy_2.0.0.9.bb b/recipes/python/python-scapy_2.0.0.9.bb
new file mode 100644
index 0000000000..ebe1223418
--- /dev/null
+++ b/recipes/python/python-scapy_2.0.0.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Scapy is a powerful interactive packet manipulation tool, \
+packet generator, network scanner, network discovery, packet sniffer, etc. \
+It can for the moment replace hping, 85% of nmap, arpspoof, arp-sk, arping, \
+tcpdump, tethereal, p0f, ...."
+SECTION = "devel/python"
+HOMEPAGE = "http://www.secdev.org/projects/scapy/"
+LICENSE = "GPL"
+PRIORITY = "optional"
+SRCNAME = "scapy"
+PR = "ml1"
+
+SRC_URI = "http://www.secdev.org/projects/scapy/files/scapy-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+RDEPENDS = "\
+ python-netclient \
+ python-netserver \
+"