aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python_2.6.5.bb
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2010-10-02 12:51:03 +0200
committerKhem Raj <raj.khem@gmail.com>2010-10-06 15:22:03 -0700
commit3b5ff5ac904475c5303bcf11962055e0253b2e6a (patch)
tree87ee5480ac85cac5a190fb99499a57a9ca0e57f2 /recipes/python/python_2.6.5.bb
parentc475f6629653994e9c2911b6d8d09aec5a063dd7 (diff)
downloadopenembedded-3b5ff5ac904475c5303bcf11962055e0253b2e6a.tar.gz
python-{native}-2.6.5: Fix parallel build.
Randomly the build failed for me with the following error message. libpython2.6.so: undefined reference to `_PyParser_Grammar' The applied patch in [5] tried to fix this problem, but it turns out that this also was due to a possible race. This is already known in OpenOffice too [3]. R. David Murray (dmalcolm) <dmalcolm@fedoraproject.org> fixed this in Fedora [1] and I applied his patch. I reported this issue upstream [4] and this will only be fixed in Python 2.7, so we have to keep this patch for Python 2.6. I put 00 in front of the name of the patch file because I did not want to rename the other patches. I build tested this with `MACHINE = " beagleboard"` for `angstrom-2008.1` and `minimal-{eglibc,uclibc,libc}`. [1] http://pkgs.fedoraproject.org/gitweb/?p=python.git;a=commitdiff;h=b95f6cc2ca6a009f97436c6aa16cfd70547353d9 [2] http://www.openoffice.org/issues/show_bug.cgi?id=114866 [3] http://doc.services.openoffice.org/wiki/RedTinderboxStatusInEIS [4] http://bugs.python.org/issue10013 [5] http://patchwork.openembedded.org/patch/1899/ Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python/python_2.6.5.bb')
-rw-r--r--recipes/python/python_2.6.5.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes/python/python_2.6.5.bb b/recipes/python/python_2.6.5.bb
index ecd9f78417..c8393c1149 100644
--- a/recipes/python/python_2.6.5.bb
+++ b/recipes/python/python_2.6.5.bb
@@ -3,10 +3,11 @@ DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl zlib\
${@base_contains('DISTRO_FEATURES', 'tk', 'tk', '', d)}"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
+ file://00-fix-parallel-make.patch \
file://00-fix-bindir-libdir-for-cross.patch \
file://01-use-proper-tools-for-cross-build.patch \
file://02-remove-test-for-cross.patch \