aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2011-02-24 10:02:54 +0000
committerKhem Raj <raj.khem@gmail.com>2011-02-23 18:44:13 -0800
commit84f27c7901934ee8c18002a0fe8872e5a03946a2 (patch)
tree524ef7306af60b0d0040c3c6546e93f863205442 /recipes/python
parentb01a76952f998e9f0d80abace8dcb6a1ddc72216 (diff)
downloadopenembedded-84f27c7901934ee8c18002a0fe8872e5a03946a2.tar.gz
python-2.6: python-xml depends on python-elementtree
* Fixes the following error: import xml.etree.cElementTree File "/usr/lib/python2.6/xml/etree/cElementTree.py", line 3, in <module> from _elementtree import * ImportError: No module named _elementtree Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-2.6-manifest.inc4
-rw-r--r--recipes/python/python_2.6.6.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes/python/python-2.6-manifest.inc b/recipes/python/python-2.6-manifest.inc
index 89c9be42dd..febaaa22bf 100644
--- a/recipes/python/python-2.6-manifest.inc
+++ b/recipes/python/python-2.6-manifest.inc
@@ -1,6 +1,6 @@
# WARNING: This file is AUTO GENERATED: Manual edits will be lost next time I regenerate the file.
-# Generator: '../../contrib/python/generate-manifest-2.6.py' Version 20110214 (C) 2002-2010 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+# Generator: 'contrib/python/generate-manifest-2.6.py' Version 20110222 (C) 2002-2010 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
# Visit the Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
@@ -254,7 +254,7 @@ RDEPENDS_${PN}-unixadmin="${PN}-core"
FILES_${PN}-unixadmin="${libdir}/python2.6/lib-dynload/nis.so ${libdir}/python2.6/lib-dynload/grp.so ${libdir}/python2.6/lib-dynload/pwd.so ${libdir}/python2.6/getpass.* "
DESCRIPTION_${PN}-xml="Python basic XML support."
-RDEPENDS_${PN}-xml="${PN}-core ${PN}-re"
+RDEPENDS_${PN}-xml="${PN}-core ${PN}-elementtree ${PN}-re"
FILES_${PN}-xml="${libdir}/python2.6/lib-dynload/pyexpat.so ${libdir}/python2.6/xml ${libdir}/python2.6/xmllib.* "
DESCRIPTION_${PN}-xmlrpc="Python XMLRPC Support"
diff --git a/recipes/python/python_2.6.6.bb b/recipes/python/python_2.6.6.bb
index c8d1c56e6d..3c054bbf6b 100644
--- a/recipes/python/python_2.6.6.bb
+++ b/recipes/python/python_2.6.6.bb
@@ -3,7 +3,7 @@ DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl zlib\
${@base_contains('DISTRO_FEATURES', 'tk', 'tk', '', d)}"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \