aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-02-14 10:24:47 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-02-14 19:44:28 +0100
commit3488225a017868d0bace67f2b0ed73afee4da010 (patch)
tree87892a914cc5b4b8bc4c065157992c4c4bb366d8 /recipes/python
parente6a1fcb4ab81809222a5f75703b0f965baffbfaf (diff)
downloadopenembedded-3488225a017868d0bace67f2b0ed73afee4da010.tar.gz
python: merge few s/python/${PN}/g from poky
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python_2.6.6.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes/python/python_2.6.6.bb b/recipes/python/python_2.6.6.bb
index 4152554eff..a4d118db21 100644
--- a/recipes/python/python_2.6.6.bb
+++ b/recipes/python/python_2.6.6.bb
@@ -92,18 +92,18 @@ do_install_append() {
require python-${PYTHON_MAJMIN}-manifest.inc
# manual dependency additions
-RPROVIDES_python-core = "python"
-RRECOMMENDS_python-core = "python-readline"
-RRECOMMENDS_python-crypt = "openssl"
+RPROVIDES_${PN}-core = "${PN}"
+RRECOMMENDS_${PN}-core = "${PN}-readline"
+RRECOMMENDS_${PN}-crypt = "openssl"
# add sitecustomize
-FILES_python-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py"
+FILES_${PN}-core += "${libdir}/python${PYTHON_MAJMIN}/sitecustomize.py"
# ship 2to3
-FILES_python-core += "${bindir}/2to3"
+FILES_${PN}-core += "${bindir}/2to3"
# package libpython2
-PACKAGES =+ "libpython2"
-FILES_libpython2 = "${libdir}/libpython*.so.*"
+PACKAGES =+ "lib${PN}2"
+FILES_lib${PN}2 = "${libdir}/libpython*.so.*"
# additional stuff -dev
@@ -121,12 +121,12 @@ FILES_${PN}-dev += "\
"
# catch debug extensions (isn't that already in python-core-dbg?)
-FILES_python-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
+FILES_${PN}-dbg += "${libdir}/python${PYTHON_MAJMIN}/lib-dynload/.debug"
# catch all the rest (unsorted)
-PACKAGES += "python-misc"
-FILES_python-misc = "${libdir}/python${PYTHON_MAJMIN}"
+PACKAGES += "${PN}-misc"
+FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN}"
# catch manpage
-PACKAGES += "python-man"
-FILES_python-man = "${datadir}/man"
+PACKAGES += "${PN}-man"
+FILES_${PN}-man = "${datadir}/man"