aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-12-13 23:28:39 +0100
committerAndrea Adami <andrea.adami@gmail.com>2010-12-14 00:29:46 +0100
commit4a7c6815cfaa9e5b706132fd92a5eae1aaf85782 (patch)
tree056681b50c8747a9787f36f06e3acd644ecf03b8 /recipes/python
parentff2ef6e71cf1d9ed184ad16a98aef7fde36bdf3b (diff)
downloadopenembedded-4a7c6815cfaa9e5b706132fd92a5eae1aaf85782.tar.gz
python-pygtksourceview: hack around PKG_CONFIG issues and unbreak build
* temporarly apply same fix (sed) used in python-pygtk * | checking for pygtk codegen... /usr/share/pygobject/2.0/codegen * | no * | configure: error: Error: codegen not found (should be shipped with pygtk!) * fix packaging of gtksourceview2.defs * bump PR Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pygtksourceview_2.6.0.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes/python/python-pygtksourceview_2.6.0.bb b/recipes/python/python-pygtksourceview_2.6.0.bb
index b5361affef..01e110f8bb 100644
--- a/recipes/python/python-pygtksourceview_2.6.0.bb
+++ b/recipes/python/python-pygtksourceview_2.6.0.bb
@@ -5,7 +5,7 @@ PRIORITY = "optional"
DEPENDS = "gtksourceview2 python-pygtk"
SRCNAME = "pygtksourceview"
LICENSE = "LGPL"
-PR = "r0"
+PR = "r1"
MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtksourceview/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2"
@@ -14,8 +14,13 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit autotools pkgconfig distutils-base
-EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+do_configure_prepend() {
+ sed -i \
+ -e s:'`$PKG_CONFIG --variable=codegendir pygtk-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ ${S}/configure.ac
+}
+FILES_${PN} += "${datadir}/pygtk/2.0/defs/gtksourceview2.defs"
SRC_URI[md5sum] = "5587a1865bd5c785c6f34095c57cc96b"
SRC_URI[sha256sum] = "77acb735fee997a1638c79256b9dcf592566d066b54a72eb4321909f98f66178"