aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-02-14 12:56:37 -0800
committerKhem Raj <raj.khem@gmail.com>2011-02-14 12:57:19 -0800
commit827af469bdd4514b9000265dc8213a3c3a09c4c5 (patch)
tree5e17c72467f2554a09c3cf15753197a909790ea6 /recipes/python
parent393c0d5bc5850592b51013d0918d0fe623d40de8 (diff)
downloadopenembedded-827af469bdd4514b9000265dc8213a3c3a09c4c5.tar.gz
python_2.6.6.bb: Fix QA ERRORS due to staging libdir in rpath
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-2.6.6/python-module-rpath-fix.patch24
-rw-r--r--recipes/python/python_2.6.6.bb3
2 files changed, 26 insertions, 1 deletions
diff --git a/recipes/python/python-2.6.6/python-module-rpath-fix.patch b/recipes/python/python-2.6.6/python-module-rpath-fix.patch
new file mode 100644
index 0000000000..a2c80895fb
--- /dev/null
+++ b/recipes/python/python-2.6.6/python-module-rpath-fix.patch
@@ -0,0 +1,24 @@
+Index: Python-2.6.5/setup.py
+===================================================================
+--- Python-2.6.5.orig/setup.py
++++ Python-2.6.5/setup.py
+@@ -973,13 +973,18 @@ class PyBuildExt(build_ext):
+ sqlite_extra_link_args = ('-Wl,-search_paths_first',)
+ else:
+ sqlite_extra_link_args = ()
++ # Check weather we are cross compiling
++ if (os.environ.get('HOST_SYS') != os.environ.get('BUILD_SYS')):
++ runtime_library_dirs_temp=[os.environ.get('libdir')]
++ else:
++ runtime_library_dirs_temp=sqlite_libdir
+
+ exts.append(Extension('_sqlite3', sqlite_srcs,
+ define_macros=sqlite_defines,
+ include_dirs=["Modules/_sqlite",
+ sqlite_incdir],
+ library_dirs=sqlite_libdir,
+- runtime_library_dirs=sqlite_libdir,
++ runtime_library_dirs=runtime_library_dirs_temp,
+ extra_link_args=sqlite_extra_link_args,
+ libraries=["sqlite3",]))
+ else:
diff --git a/recipes/python/python_2.6.6.bb b/recipes/python/python_2.6.6.bb
index a4d118db21..c8d1c56e6d 100644
--- a/recipes/python/python_2.6.6.bb
+++ b/recipes/python/python_2.6.6.bb
@@ -3,7 +3,7 @@ DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl zlib\
${@base_contains('DISTRO_FEATURES', 'tk', 'tk', '', d)}"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -15,6 +15,7 @@ SRC_URI = "\
file://05-enable-ctypes-cross-build.patch \
file://06-ctypes-libffi-fix-configure.patch \
file://ipv6-cross.patch \
+ file://python-module-rpath-fix.patch \
file://sitecustomize.py \
"
SRC_URI[md5sum] = "cf4e6881bb84a7ce6089e4a307f71f14"