aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-07-08 14:07:50 -0700
committerTom Rini <tom_rini@mentor.com>2010-07-08 14:07:50 -0700
commita753e680011a9843e0cd0ee928fd508667445d00 (patch)
tree9c8f5d06b35482ba9699b20a8a91ea240fb8d09e /recipes/python
parent51ee5b59b47d44c4bda49435e08487b983626254 (diff)
downloadopenembedded-a753e680011a9843e0cd0ee928fd508667445d00.tar.gz
python-native: Switch to non-legacy staging
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-native_2.6.1.bb6
-rw-r--r--recipes/python/python-native_2.6.4.bb6
2 files changed, 6 insertions, 6 deletions
diff --git a/recipes/python/python-native_2.6.1.bb b/recipes/python/python-native_2.6.1.bb
index 44da281d62..18002df3ae 100644
--- a/recipes/python/python-native_2.6.1.bb
+++ b/recipes/python/python-native_2.6.1.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -25,8 +25,8 @@ EXTRA_OEMAKE = '\
STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
'
-do_stage_append() {
- install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen
+do_install_append() {
+ install -m 0755 Parser/pgen ${D}${bindir}/pgen
}
SRC_URI[md5sum] = "e81c2f0953aa60f8062c05a4673f2be0"
diff --git a/recipes/python/python-native_2.6.4.bb b/recipes/python/python-native_2.6.4.bb
index 4205312978..0f57c4c6ba 100644
--- a/recipes/python/python-native_2.6.4.bb
+++ b/recipes/python/python-native_2.6.4.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
@@ -29,6 +29,6 @@ EXTRA_OEMAKE = '\
STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
'
-do_stage_append() {
- install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen
+do_install_append() {
+ install -m 0755 Parser/pgen ${D}${bindir}/pgen
}