aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-12-13 23:31:33 +0100
committerAndrea Adami <andrea.adami@gmail.com>2010-12-14 00:29:51 +0100
commit61b4857eac214341aeb32975ed5f903721a603fa (patch)
tree24a434c7feef8d113a1cf5bc6a9c83f7d4cf09b0 /recipes/python
parent4a7c6815cfaa9e5b706132fd92a5eae1aaf85782 (diff)
downloadopenembedded-61b4857eac214341aeb32975ed5f903721a603fa.tar.gz
python-pygtksourceview: add latest version 2.10.1
* apply hack around PKG_CONFIG until the issue is sanitized in python Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pygtksourceview_2.10.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/python/python-pygtksourceview_2.10.1.bb b/recipes/python/python-pygtksourceview_2.10.1.bb
new file mode 100644
index 0000000000..0730cf41c4
--- /dev/null
+++ b/recipes/python/python-pygtksourceview_2.10.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Python gtksourceview Bindings"
+SECTION = "devel/python"
+HOMEPAGE = "http://projects.gnome.org/gtksourceview/pygtksourceview.html"
+PRIORITY = "optional"
+DEPENDS = "gtksourceview2 python-pygtk"
+SRCNAME = "pygtksourceview"
+LICENSE = "LGPL"
+PR = "r0"
+
+MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtksourceview/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit autotools pkgconfig distutils-base
+
+do_configure_prepend() {
+ sed -i \
+ -e s:'`$PKG_CONFIG --variable=codegendir pygtk-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
+ ${S}/configure.ac
+}
+
+FILES_${PN} += "${datadir}/pygtk/2.0/defs/gtksourceview2.defs"
+
+SRC_URI[md5sum] = "2654354d61422fb79d8375fc3a3b5393"
+SRC_URI[sha256sum] = "b4b47c5aeb67a26141cb03663091dfdf5c15c8a8aae4d69c46a6a943ca4c5974"