aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-01-08 15:47:54 +0100
committerKoen Kooi <koen@openembedded.org>2011-01-08 15:47:54 +0100
commitbc6a94559157e6fcc190a22a259c0f757b8664ae (patch)
tree24283f491bccadc0900c96dda4f4b5d288434c06 /recipes/python
parent19dacc762716ce7dc70b1cad62b3af6530a46e41 (diff)
downloadopenembedded-bc6a94559157e6fcc190a22a259c0f757b8664ae.tar.gz
python-lxml: add 2.2.8
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-lxml_2.2.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/python/python-lxml_2.2.8.bb b/recipes/python/python-lxml_2.2.8.bb
new file mode 100644
index 0000000000..9eb927c2f0
--- /dev/null
+++ b/recipes/python/python-lxml_2.2.8.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Powerful and Pythonic XML processing library combining \
+libxml2/libxslt with the ElementTree API."
+HOMEPAGE = "http://codespeak.net/lxml"
+LICENSE = "BSD"
+SRCNAME = "lxml"
+
+DEPENDS = "libxml2 libxslt"
+RDEPENDS_${PN} += "libxml2 libxslt python-compression"
+
+SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml"
+SRC_URI[lxml.md5sum] = "d6c612d63a84d79440912a1b29d3b981"
+SRC_URI[lxml.sha256sum] = "89b73925b5e3295dcf4675cb948007a20eb029fe35c9a162ae19ec11f1abafe5"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+DISTUTILS_BUILD_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_NATIVE}/xml2-config' \
+"
+
+DISTUTILS_INSTALL_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_NATIVE}/xml2-config' \
+"