aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2010-11-12 00:00:20 -0500
committerCliff Brake <cbrake@bec-systems.com>2010-11-12 00:00:20 -0500
commit3c6efe8f8abc16668ca5e9cdf7a46665dac87172 (patch)
tree642c13416b99e80f0871cdc6668e832e635dfb48 /recipes/python
parentc400c874f2ac9233b8a43a73309b6e7907289c54 (diff)
parent13fbe7253c95881ede787004a4c3a1c31502e5c6 (diff)
downloadopenembedded-testing.tar.gz
Merge branch 'master' into testing-nexttested_2010-11-12testing
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-pyxdg/desktopentry-cmp.patch15
-rw-r--r--recipes/python/python-pyxdg_0.15.bb4
2 files changed, 18 insertions, 1 deletions
diff --git a/recipes/python/python-pyxdg/desktopentry-cmp.patch b/recipes/python/python-pyxdg/desktopentry-cmp.patch
new file mode 100644
index 0000000000..bb2905ab3d
--- /dev/null
+++ b/recipes/python/python-pyxdg/desktopentry-cmp.patch
@@ -0,0 +1,15 @@
+This method definition causes an infinite recursion, and has been dropped
+from later releases.
+
+--- pyxdg-0.15/xdg/DesktopEntry.py.orig 2010-08-03 03:01:34.000000000 +0200
++++ pyxdg-0.15/xdg/DesktopEntry.py 2010-08-03 03:01:46.000000000 +0200
+@@ -29,9 +29,6 @@
+ def __str__(self):
+ return self.getName()
+
+- def __cmp__(self, other):
+- return cmp(self, other)
+-
+ def parse(self, file):
+ IniFile.parse(self, file, ["Desktop Entry", "KDE Desktop Entry"])
+
diff --git a/recipes/python/python-pyxdg_0.15.bb b/recipes/python/python-pyxdg_0.15.bb
index 018af5029c..67b6c979fc 100644
--- a/recipes/python/python-pyxdg_0.15.bb
+++ b/recipes/python/python-pyxdg_0.15.bb
@@ -1,9 +1,11 @@
DESCRIPTION = "PyXDG is a python library to access freedesktop.org standards"
SECTION = "devel/python"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.freedesktop.org/~lanius/pyxdg-${PV}.tar.gz"
+SRC_URI += "file://desktopentry-cmp.patch"
+
S = "${WORKDIR}/pyxdg-${PV}"
inherit distutils