summaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mlauer@vanille-media.de>2010-07-11 15:54:14 +0200
committerMichael 'Mickey' Lauer <mlauer@vanille-media.de>2010-07-11 15:54:14 +0200
commit58abfe62fe89b3fe87a8b9a183b189103ae1570f (patch)
tree5cea4760a3715e019eff9cf653fbb0b03e0bcdc5 /recipes/python
parent2cc5b6a0736853d808b12d6d7803c223b555a5e4 (diff)
downloadopenembedded-58abfe62fe89b3fe87a8b9a183b189103ae1570f.tar.gz
python 2.6: add python-numbers subpackage adding support for numerical APIs:
Included for now are the modules numbers and decimal
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-native_2.6.4.bb3
-rw-r--r--recipes/python/python.inc2
-rw-r--r--recipes/python/python_2.6.4.bb2
3 files changed, 4 insertions, 3 deletions
diff --git a/recipes/python/python-native_2.6.4.bb b/recipes/python/python-native_2.6.4.bb
index 0f57c4c6ba..ccb6409e26 100644
--- a/recipes/python/python-native_2.6.4.bb
+++ b/recipes/python/python-native_2.6.4.bb
@@ -1,6 +1,7 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
-PR = "${INC_PR}.4"
+# set to 0 on every increase of INC_PR
+PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
diff --git a/recipes/python/python.inc b/recipes/python/python.inc
index aff18db6f8..1e73d103c7 100644
--- a/recipes/python/python.inc
+++ b/recipes/python/python.inc
@@ -4,7 +4,7 @@ LICENSE = "PSF"
SECTION = "devel/python"
PRIORITY = "optional"
# bump this on every change in contrib/python/generate-manifest-2.6.py
-INC_PR = "ml9"
+INC_PR = "ml10"
DEFAULT_PREFERENCE = "-26"
diff --git a/recipes/python/python_2.6.4.bb b/recipes/python/python_2.6.4.bb
index 84234f7e4d..1d91d47304 100644
--- a/recipes/python/python_2.6.4.bb
+++ b/recipes/python/python_2.6.4.bb
@@ -3,7 +3,7 @@ DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl zlib\
${@base_contains('DISTRO_FEATURES', 'tk', 'tk', '', d)}"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# set to .0 on every increase of INC_PR
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.0"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \