aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qemu
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-15 23:55:00 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-16 22:46:40 +0300
commit2465c93bcb894b109badf81fdde2445c8d6ff363 (patch)
tree23e04d536621f5d01e46509abf8a63920c9746e5 /recipes/qemu
parentba37428a7e91205ad205bcf4d19268b6fe73844e (diff)
downloadopenembedded-2465c93bcb894b109badf81fdde2445c8d6ff363.tar.gz
qemu: fix build with zlib-dev missing on host
OE provides its own zlib-native and qemu-native should use that. Thanks to Thomas Zimmermann <ml@vdm-design.de> for spotting it. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/qemu')
-rw-r--r--recipes/qemu/qemu_0.12.3.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/qemu/qemu_0.12.3.bb b/recipes/qemu/qemu_0.12.3.bb
index 035b1a5b3a..d1971e96f8 100644
--- a/recipes/qemu/qemu_0.12.3.bb
+++ b/recipes/qemu/qemu_0.12.3.bb
@@ -1,7 +1,7 @@
LICENSE = "GPL"
DEPENDS = "zlib"
-PR = "r0"
+PR = "r1"
SRC_URI = "\
http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz;name=qemu-${PV} \
@@ -31,6 +31,10 @@ EXTRA_OECONF += "--disable-sdl --disable-strip"
inherit autotools
+do_configure_prepend_virtclass-native() {
+ export QEMU_CFLAGS="-I${STAGING_INCDIR_NATIVE} ${QEMU_CFLAGS}"
+}
+
do_configure() {
${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
}