aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qemu
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-02 18:03:07 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2010-06-02 18:03:07 +0400
commit330d29167fa1267fb3504107a66e22b84f86d7e5 (patch)
treedc6eeada37502633b402861603ffece1deeafa2f /recipes/qemu
parent2cfe2706323c88fedbf8340ebbdecf403d26558b (diff)
downloadopenembedded-330d29167fa1267fb3504107a66e22b84f86d7e5.tar.gz
qemu: fix the fix for qemu-native vs. no zlib on host
Make the qemu virtual:native build to pass staging dir via EXTRA_OECONF, not via QEMU_CFLAGS, which aren't passed to configure environment. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
Diffstat (limited to 'recipes/qemu')
-rw-r--r--recipes/qemu/qemu_0.12.3.bb6
-rw-r--r--recipes/qemu/qemu_0.12.4.bb6
2 files changed, 4 insertions, 8 deletions
diff --git a/recipes/qemu/qemu_0.12.3.bb b/recipes/qemu/qemu_0.12.3.bb
index db9155c4e3..9ee512d31d 100644
--- a/recipes/qemu/qemu_0.12.3.bb
+++ b/recipes/qemu/qemu_0.12.3.bb
@@ -32,11 +32,9 @@ S = "${WORKDIR}/qemu-${PV}"
EXTRA_OECONF += " --disable-curl --disable-sdl --disable-strip"
-inherit autotools
+EXTRA_OECONF_append_virtclass-native += " --extra-cflags="-I${STAGING_INCDIR_NATIVE}""
-do_configure_prepend_virtclass-native() {
- export QEMU_CFLAGS="-I${STAGING_INCDIR_NATIVE} ${QEMU_CFLAGS}"
-}
+inherit autotools
do_configure() {
${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
diff --git a/recipes/qemu/qemu_0.12.4.bb b/recipes/qemu/qemu_0.12.4.bb
index 6bc5868f64..7013702d9f 100644
--- a/recipes/qemu/qemu_0.12.4.bb
+++ b/recipes/qemu/qemu_0.12.4.bb
@@ -29,11 +29,9 @@ S = "${WORKDIR}/qemu-${PV}"
EXTRA_OECONF += " --disable-curl --disable-sdl --disable-strip \
"
-inherit autotools
+EXTRA_OECONF_append_virtclass-native += " --extra-cflags="-I${STAGING_INCDIR_NATIVE}""
-do_configure_prepend_virtclass-native() {
- export QEMU_CFLAGS="-I${STAGING_INCDIR_NATIVE} ${QEMU_CFLAGS}"
-}
+inherit autotools
do_configure() {
${S}/configure --prefix=${prefix} ${EXTRA_OECONF}