aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qof
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qof
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qof')
-rw-r--r--recipes/qof/files/fix-includes.patch16
-rw-r--r--recipes/qof/files/libsql-no-host-includes.patch12
-rw-r--r--recipes/qof/qof_0.6.0.bb20
-rw-r--r--recipes/qof/qof_0.7.2.bb21
4 files changed, 69 insertions, 0 deletions
diff --git a/recipes/qof/files/fix-includes.patch b/recipes/qof/files/fix-includes.patch
new file mode 100644
index 0000000000..427a88d0ee
--- /dev/null
+++ b/recipes/qof/files/fix-includes.patch
@@ -0,0 +1,16 @@
+--- /tmp/Makefile.am 2005-11-13 21:41:47.368686720 +0100
++++ qof-0.6.0-pre1/qof/Makefile.am 2005-11-13 21:41:58.637973528 +0100
+@@ -86,13 +86,11 @@
+
+ if USE_LIBGDA
+ INCLUDES = \
+- -I$(includedir) \
+ -DPREFIX=\""$(prefix)"\" \
+ -DDATADIR=\""$(datadir)"\"
+ else
+ INCLUDES = \
+ -I${top_srcdir}/lib/libsql \
+- -I$(includedir) \
+ -DPREFIX=\""$(prefix)"\" \
+ -DDATADIR=\""$(datadir)"\"
+ endif
diff --git a/recipes/qof/files/libsql-no-host-includes.patch b/recipes/qof/files/libsql-no-host-includes.patch
new file mode 100644
index 0000000000..345aa2d4ba
--- /dev/null
+++ b/recipes/qof/files/libsql-no-host-includes.patch
@@ -0,0 +1,12 @@
+--- /tmp/Makefile.am 2006-12-30 13:42:56.000000000 +0100
++++ qof-0.6.0/lib/libsql/Makefile.am 2006-12-30 13:46:03.952227000 +0100
+@@ -30,9 +30,6 @@
+ @CFLAGS@ \
+ @GLIB_CFLAGS@
+
+-INCLUDES = \
+- -I$(includedir)
+-
+ parser.c: parser.y
+ $(YACC) -v -d -o parser.c -p sql parser.y
+
diff --git a/recipes/qof/qof_0.6.0.bb b/recipes/qof/qof_0.6.0.bb
new file mode 100644
index 0000000000..9c35993cb7
--- /dev/null
+++ b/recipes/qof/qof_0.6.0.bb
@@ -0,0 +1,20 @@
+HOMEPAGE = "http://qof.sourceforge.net/"
+LICENSE = "GPL"
+
+DEPENDS = "glib-2.0 libxml2 libtool zlib"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz \
+ file://libsql-no-host-includes.patch;patch=1 \
+ file://fix-includes.patch;patch=1 \
+ "
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "/usr/share/xml"
+
diff --git a/recipes/qof/qof_0.7.2.bb b/recipes/qof/qof_0.7.2.bb
new file mode 100644
index 0000000000..e6bae9e5c9
--- /dev/null
+++ b/recipes/qof/qof_0.7.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "set of C Language utilities for performing generic structured \
+complex queries on a set of data held by a set of C/C++ objects."
+AUTHOR = "Linas Vepstas, Neil Williams"
+HOMEPAGE = "http://qof.sf.net/"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 libxml2 libtool zlib"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz \
+ "
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-error-on-warning"
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "/usr/share/xml"
+