aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qpe-gaim/qpe-libgaim_1.5.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qpe-gaim/qpe-libgaim_1.5.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qpe-gaim/qpe-libgaim_1.5.0.bb')
-rw-r--r--recipes/qpe-gaim/qpe-libgaim_1.5.0.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes/qpe-gaim/qpe-libgaim_1.5.0.bb b/recipes/qpe-gaim/qpe-libgaim_1.5.0.bb
new file mode 100644
index 0000000000..4483b8cce7
--- /dev/null
+++ b/recipes/qpe-gaim/qpe-libgaim_1.5.0.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "A multi protocol instant messager library, Qt/Embedded based Palmtop Environments Edition"
+SECTION = "opie/applications"
+DEPENDS = "glib-2.0 gnutls"
+RDEPENDS = "libgaim-plugins"
+LICENSE = "GPL"
+HOMEPAGE = "http://gaim.sourceforge.net/"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gaim/gaim-${PV}.tar.bz2 \
+ file://dont-look-for-gtk.patch;patch=1 \
+ file://libgaim.patch;patch=1 "
+
+S = "${WORKDIR}/gaim-${PV}"
+
+inherit autotools
+
+EXTRA_OE_CONF = "--disable-audio --disable-gtkspell --disable-perl \
+ --disable-screensaver --disable-sm --disable-glibtest \
+ --disable-gtktest --disable-startup-notification \
+ --disable-gevolution --disable-aotest --disable-audiofiletest \
+ --disable-x --without-x --without-gtk --disable-gtk \
+ --enable-gnutls=y"
+
+CFLAGS_append = " -I${STAGING_INCDIR}/glib-2.0"
+
+do_stage() {
+ oe_libinstall -so -C src libgaim ${QTDIR}/lib
+
+ # install headers
+ GAIM_DIR=${STAGING_INCDIR}/gaim
+ install -d $GAIM_DIR
+
+ for header in account.h accountopt.h away.h blist.h buddyicon.h cmds.h config.h connection.h conversation.h core.h debug.h eventloop.h ft.h gaim.h imgstore.h log.h md5.h network.h notify.h plugin.h pluginpref.h pounce.h prefix.h prefs.h privacy.h proxy.h prpl.h request.h roomlist.h server.h sha.h signals.h sound.h sslconn.h status.h stringref.h util.h value.h version.h xmlnode.h
+ do
+ if [ -e ${S}/src/$header ]; then
+ install -m 0644 ${S}/src/$header $GAIM_DIR
+ fi
+ if [ -e ${S}/$header ]; then
+ install -m 0644 ${S}/$header $GAIM_DIR
+ fi
+ done
+}
+
+PACKAGES_DYNAMIC = "libgaim-protocol-*"
+
+#FIXME: use do_packages to create individual packages for each of the plugins
+python populate_packages_prepend () {
+ plugindir = bb.data.expand('${libdir}/gaim', d)
+ do_split_packages(d, plugindir, '^lib(.*)\.so$', 'libgaim-protocol-%s', 'GAIM plugin for %s protocol', extra_depends='' )
+}
+
+PACKAGES += "libgaim-plugins"
+FILES_libgaim-plugins = "${libdir}/gaim/autorecon.so ${libdir}/gaim/s*.so"
+