aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qpe-nmap
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qpe-nmap
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qpe-nmap')
-rw-r--r--recipes/qpe-nmap/qpe-nmap_0.02.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/qpe-nmap/qpe-nmap_0.02.bb b/recipes/qpe-nmap/qpe-nmap_0.02.bb
new file mode 100644
index 0000000000..43cd451957
--- /dev/null
+++ b/recipes/qpe-nmap/qpe-nmap_0.02.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A frontend for the nmap port scanner, Qt/Embedded Palmtop Environment"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "nmap"
+PR = "r0"
+
+SRC_URI = "http://www.bluelightning.org/qpe-nmap/files/qpe-nmap-${PV}.tar.bz2"
+
+APPNAME = "qpe-nmap"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+
+S = "${WORKDIR}/qpe-nmap"
+
+inherit opie
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/qpe-nmap/ipk/opt/QtPalmtop/pics/qpe-nmap.png ${D}${palmtopdir}/pics/
+ install -d ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${WORKDIR}/qpe-nmap/ipk/opt/QtPalmtop/apps/Applications/qpe-nmap.desktop ${D}${palmtopdir}/apps/Applications/
+}
+