aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-03-16 11:30:12 -0700
committerSteffen Sledz <sledz@dresearch-fe.de>2011-04-29 14:08:38 +0200
commitc314226d4679d4ac321d48f52047254d4dca20b5 (patch)
treef8e162cfafcc2ed134cce186cbb5b0f0a834afc9 /recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
parentadf9708f3c4fe07cfa03f429d59bf6038af1b465 (diff)
downloadopenembedded-c314226d4679d4ac321d48f52047254d4dca20b5.tar.gz
qscintilla 1.65-gpl-1.6: Rework no-external-lexers.patch
Also drop do_stage and update do_install while in here. Signed-off-by: Tom Rini <tom_rini@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb')
-rw-r--r--recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb b/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
index cfed35c561..a88bf372b2 100644
--- a/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
+++ b/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Qt/Embedded bindings for the Scintilla source code editor component"
SECTION = "opie/libs"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz \
- file://no-external-lexers.patch;striplevel=0"
+ file://no-external-lexers.patch;apply=false"
S = "${WORKDIR}/qscintilla-${PV}/qt"
@@ -22,14 +22,14 @@ EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/patches \
PARALLEL_MAKE = ""
-do_stage() {
- install -m 0644 qextscintilla*.h ${STAGING_INCDIR}/
- oe_libinstall -so libqscintilla ${STAGING_LIBDIR}
+do_configure_prepend() {
+ (cd .. ; patch -p0 -i ${WORKDIR}/no-external-lexers.patch)
}
do_install() {
- install -d ${D}${libdir}
+ install -d ${D}${libdir} ${D}${includedir}
oe_libinstall -so libqscintilla ${D}${libdir}
+ install -m 0644 qextscintilla*.h ${D}${includedir}/
}
FILES_${PN} = "${libdir}"