aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qscintilla
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qscintilla
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qscintilla')
-rw-r--r--recipes/qscintilla/files/no-external-lexers.patch24
-rw-r--r--recipes/qscintilla/qscintilla_1.60-gpl-1.3.bb16
-rw-r--r--recipes/qscintilla/qscintilla_1.60-gpl-1.3b.bb16
-rw-r--r--recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb35
4 files changed, 91 insertions, 0 deletions
diff --git a/recipes/qscintilla/files/no-external-lexers.patch b/recipes/qscintilla/files/no-external-lexers.patch
new file mode 100644
index 0000000000..5953043190
--- /dev/null
+++ b/recipes/qscintilla/files/no-external-lexers.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- ../src/ExternalLexer.cpp~no-external-lexers
++++ ../src/ExternalLexer.cpp
+@@ -110,7 +110,7 @@
+ // Initialise some members...
+ first = NULL;
+ last = NULL;
+-
++#ifndef ZPATCH
+ // Load the DLL
+ lib = DynamicLibrary::Load(ModuleName);
+ if (lib->IsValid()) {
+@@ -155,6 +155,7 @@
+ }
+ }
+ }
++#endif
+ next = NULL;
+ }
+
diff --git a/recipes/qscintilla/qscintilla_1.60-gpl-1.3.bb b/recipes/qscintilla/qscintilla_1.60-gpl-1.3.bb
new file mode 100644
index 0000000000..a983e7f1b4
--- /dev/null
+++ b/recipes/qscintilla/qscintilla_1.60-gpl-1.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Qt/Embedded bindings for the Scintilla source code editor component"
+SECTION = "opie/libs"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz"
+S = "${WORKDIR}/qscintilla-${PV}/qt"
+
+inherit opie
+
+QMAKE_PROFILES = "qscintilla.pro"
+
+do_stage() {
+ install -m 0644 qextscintilla*.h ${STAGING_INCDIR}/
+ install -m 0644 libqscintilla.a ${STAGING_LIBDIR}/
+}
diff --git a/recipes/qscintilla/qscintilla_1.60-gpl-1.3b.bb b/recipes/qscintilla/qscintilla_1.60-gpl-1.3b.bb
new file mode 100644
index 0000000000..afcd3041d0
--- /dev/null
+++ b/recipes/qscintilla/qscintilla_1.60-gpl-1.3b.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Qt/Embedded bindings for the Scintilla source code editor component"
+SECTION = "opie/libs"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz"
+S = "${WORKDIR}/qscintilla-1.60-gpl-1.3/qt"
+
+inherit opie
+
+QMAKE_PROFILES = "qscintilla.pro"
+
+do_stage() {
+ install -m 0644 qextscintilla*.h ${STAGING_INCDIR}/
+ install -m 0644 libqscintilla.a ${STAGING_LIBDIR}/
+}
diff --git a/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb b/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
new file mode 100644
index 0000000000..3acb29e3fa
--- /dev/null
+++ b/recipes/qscintilla/qscintilla_1.65-gpl-1.6.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Qt/Embedded bindings for the Scintilla source code editor component"
+SECTION = "opie/libs"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz \
+ file://no-external-lexers.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/qscintilla-${PV}/qt"
+
+inherit opie
+
+QMAKE_PROFILES = "qscintilla.pro"
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/patches \
+ DEFINES+=ZPATCH DEFINES+=ZAURUS \
+ HEADERS-=qextscintillaprinter.h \
+ SOURCES-=qextscintillaprinter.cpp \
+ SOURCES+=patches/qsettings.cpp \
+ SOURCES+=patches/qsettings_unix.cpp \
+ HEADERS+=patches/qsettings.h"
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ install -m 0644 qextscintilla*.h ${STAGING_INCDIR}/
+ oe_libinstall -so libqscintilla ${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ oe_libinstall -so libqscintilla ${D}${libdir}
+}
+
+FILES_${PN} = "${libdir}"