aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4/qt4-embedded_4.5.1.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-24 08:43:51 +0200
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-24 08:43:51 +0200
commitf5daa62a4430164c4f9f7c34e8d7c53e37af8875 (patch)
treeed48df478ce5534a471c4583aae5e0909583b992 /recipes/qt4/qt4-embedded_4.5.1.bb
parent9d54794e4edd80519e7c0ea47c0b107ab648c94f (diff)
downloadopenembedded-f5daa62a4430164c4f9f7c34e8d7c53e37af8875.tar.gz
qt4: update from 4.5.0 to 4.5.1
Diffstat (limited to 'recipes/qt4/qt4-embedded_4.5.1.bb')
-rw-r--r--recipes/qt4/qt4-embedded_4.5.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/qt4/qt4-embedded_4.5.1.bb b/recipes/qt4/qt4-embedded_4.5.1.bb
new file mode 100644
index 0000000000..5da55f9c1c
--- /dev/null
+++ b/recipes/qt4/qt4-embedded_4.5.1.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Qt is a versatile cross-platform application framework -- this is the embedded version."
+SECTION = "libs"
+LICENSE = "GPL LGPL QPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+DEPENDS += "tslib"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://${PV}/0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://${PV}/0006-freetype-host-includes.patch;patch=1 \
+ file://${PV}/0007-openssl-host-includes.patch;patch=1 \
+ file://${PV}/0008-qt-lib-infix.patch;patch=1 \
+ file://0009-support-2bpp.patch;patch=1 \
+ file://${PV}/0010-no-simpledecoration-example.patch;patch=1 \
+ file://g++.conf \
+ file://linux.conf \
+ "
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+
+QT_CONFIG_FLAGS += " \
+ -qtlibinfix E \
+ -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
+ -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc \
+ -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb \
+ -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb \
+ -DQT_KEYPAD_NAVIGATION \
+ "
+
+QT_BASE_NAME = "qt4-embedded"
+QT_BASE_LIB = "libqt-embedded"
+QT_DIR_NAME = "qtopia"
+QT_LIBINFIX="E"
+
+require qt4.inc
+
+inherit qt4e