aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4/qt4-tools-native_4.4.3.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-03-26 16:54:09 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-03-26 16:54:09 +0100
commit0f8afdb545bbac27832589e9b566025c5f314450 (patch)
treefb3bd6c52bf01dc76284fb3ee6a68d826f5f5724 /recipes/qt4/qt4-tools-native_4.4.3.bb
parent318dd21d6e354f5b2002de71cc4ab6baa0c9ad4c (diff)
downloadopenembedded-0f8afdb545bbac27832589e9b566025c5f314450.tar.gz
qt4: add initial version of qt4-tools-native 4.5.0
Diffstat (limited to 'recipes/qt4/qt4-tools-native_4.4.3.bb')
-rw-r--r--recipes/qt4/qt4-tools-native_4.4.3.bb71
1 files changed, 2 insertions, 69 deletions
diff --git a/recipes/qt4/qt4-tools-native_4.4.3.bb b/recipes/qt4/qt4-tools-native_4.4.3.bb
index 03bffcce6d..8a8d46fb8d 100644
--- a/recipes/qt4/qt4-tools-native_4.4.3.bb
+++ b/recipes/qt4/qt4-tools-native_4.4.3.bb
@@ -1,69 +1,2 @@
-DESCRIPTION = "Native tools for Qt/[X11|Mac|Embedded] version 4.x"
-DEPENDS = "zlib-native"
-SECTION = "libs"
-HOMEPAGE = "http://www.trolltech.com"
-PRIORITY = "optional"
-LICENSE = "GPL"
-PR = "r1"
-
-inherit native
-
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
- file://0005-fix-mkspecs.patch;patch=1 \
- file://qt-config.patch;patch=1"
-S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
-
-EXTRA_OECONF = "-prefix ${prefix} \
- -qt-libjpeg -qt-gif -system-zlib \
- -no-nis -no-cups -no-exceptions \
- -no-accessibility -no-libjpeg \
- -no-nas-sound -no-sm \
- -no-xshape -no-xinerama \
- -no-xcursor -no-xrandr \
- -no-xrender -no-fontconfig \
- -no-tablet -no-xkb \
- -no-libpng \
- -verbose -release -fast -static \
- -qt3support "
-
-# yank default -e, otherwise we get the following error:
-# moc_qbuffer.cpp: No such file or directory
-EXTRA_OEMAKE = " "
-
-do_configure() {
- ln -s linux-g++ mkspecs/${BUILD_OS}-oe-g++
- echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
-}
-
-TOBUILD = "\
- src/tools/moc \
- src/corelib \
- src/sql \
- src/qt3support \
- src/xml \
- src/tools/uic \
- src/tools/rcc \
- src/network \
- src/gui \
- src/tools/uic3 \
- tools/linguist/lrelease \
- tools/linguist/lupdate \
-"
-
-do_compile() {
- for i in ${TOBUILD}; do
- cd ${S}/$i && oe_runmake CC="${CC}" CXX="${CXX}"
- done
-}
-
-do_stage() {
- install -d ${STAGING_BINDIR_NATIVE}/
- install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake2
- for i in moc uic uic3 rcc lrelease lupdate; do
- install -m 0755 bin/${i} ${STAGING_BINDIR_NATIVE}/${i}4
- done
- install -d ${STAGING_DATADIR_NATIVE}/qt4/
- cp -PfR mkspecs ${STAGING_DATADIR_NATIVE}/qt4/
- install -m 0644 tools/porting/src/q3porting.xml ${STAGING_DATADIR_NATIVE}/qt4/
-}
-
+require qt4-tools-native.inc
+PR = "r2"