aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4/qt4-tools-native_4.4.3.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-02-17 11:39:34 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-18 14:33:34 +0100
commit357e89f526a8b50f71e9cc815d4eeee8b78cb8d3 (patch)
treeb5b6bf0ff4d037950ffe189fa09212a3a304b9c7 /recipes/qt4/qt4-tools-native_4.4.3.bb
parentb377f83fde485aa4f1bf3f99e907d89bfdd7686d (diff)
downloadopenembedded-357e89f526a8b50f71e9cc815d4eeee8b78cb8d3.tar.gz
qt4-tools-native: set libdir and incdir in .inc file
* move SRC_URI and EXTRA_OECONF for new versions to .inc and changed to old version * remove LFLAGS setting from 4.6.* versions (replaced with -L param) * Idea also Acked-by: Holger Hans Peter Freyther <zecke@selfish.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/qt4/qt4-tools-native_4.4.3.bb')
-rw-r--r--recipes/qt4/qt4-tools-native_4.4.3.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/qt4/qt4-tools-native_4.4.3.bb b/recipes/qt4/qt4-tools-native_4.4.3.bb
index a734b6b936..3ad402f0ed 100644
--- a/recipes/qt4/qt4-tools-native_4.4.3.bb
+++ b/recipes/qt4/qt4-tools-native_4.4.3.bb
@@ -1,2 +1,18 @@
require qt4-tools-native.inc
+
+# Older releases have different source archive name, than .inc
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://configure-lflags.patch;patch=1 \
+ file://qt-config.patch;patch=1 \
+ file://g++.conf \
+ file://linux.conf"
+
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+
+EXTRA_OECONF += " -fast"
+
+do_configure() {
+ (echo o; echo yes) | LFLAGS="-L${STAGING_LIBDIR_NATIVE}" ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
+}
+
PR = "${INC_PR}.1"