aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 10:39:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-12 20:16:13 +0200
commit16f464bd8cff6b6a27d9bfe691f7adc875d01ac2 (patch)
treed235ad1dba36225ca211cc7c606ecaab4ff883c5 /recipes/qt4
parent44985d56bc556786812a0a02d6219afd31a7381d (diff)
downloadopenembedded-16f464bd8cff6b6a27d9bfe691f7adc875d01ac2.tar.gz
recipes: move checksums to recipes from checksums.ini, part 2 manual adjustement
* all: multiple checked items in SRC_URI (needs name= param) * other fixes like non-existent URL, checksums moved ot .inc or included .bb (ie for -native) * ... * tested with micro/micro-uclibc/Angstrom/SHR with SOURCE_MIRROR_FETCH="True" (ignoring COMPATIBLE_* * also tested -c fetch with s/SRC_URI_append_[^ ]*/SRC_URI_append/g and s/SRC_URI_[^ ]*/SRC_URI_append/g to catch all URLs used only for distro/machine/virtual override (see http://build.shr-project.org/tests/jama/SRC_URI.removeOverrides.patch) * in case I downloaded different checksum then what was in checksums.ini I used the old one from checksums.ini and put my checksum in comment * I'll send to ML list of recipes which cannot be downloaded (weren't converted) and where I got different checksums Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/qt-4.6.0.inc3
-rw-r--r--recipes/qt4/qt-4.6.2.inc3
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.6.0.bb5
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.6.2.bb5
-rw-r--r--recipes/qt4/qt4-embedded_4.6.0.bb4
-rw-r--r--recipes/qt4/qt4-embedded_4.6.2.bb4
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.6.0.bb5
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.6.2.bb5
-rw-r--r--recipes/qt4/qt4-x11-free_4.6.0.bb5
-rw-r--r--recipes/qt4/qt4-x11-free_4.6.2.bb5
10 files changed, 6 insertions, 38 deletions
diff --git a/recipes/qt4/qt-4.6.0.inc b/recipes/qt4/qt-4.6.0.inc
index 91565f7e0e..c273a81397 100644
--- a/recipes/qt4/qt-4.6.0.inc
+++ b/recipes/qt4/qt-4.6.0.inc
@@ -75,3 +75,6 @@ do_install_append() {
LICENSE = "LGPLv2.1 GPLv3"
SRC_URI += " \
file://hack-out-pg_config.patch;patch=1"
+
+SRC_URI[md5sum] = "2a7b5126f2450d8525af355fc4c12ad6"
+SRC_URI[sha256sum] = "55259c813324f6383cbd441aa2f23e01c320b6d63fbe3b5d52a7715055d28589"
diff --git a/recipes/qt4/qt-4.6.2.inc b/recipes/qt4/qt-4.6.2.inc
index 83fe431ae3..3ec329f373 100644
--- a/recipes/qt4/qt-4.6.2.inc
+++ b/recipes/qt4/qt-4.6.2.inc
@@ -59,3 +59,6 @@ do_install_append() {
LICENSE = "LGPLv2.1 GPLv3"
SRC_URI += " \
file://hack-out-pg_config.patch;patch=1"
+
+SRC_URI[md5sum] = "eb651ee4b157c01696aa56777fc6e0e5"
+SRC_URI[sha256sum] = "176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae"
diff --git a/recipes/qt4/qt4-embedded-gles_4.6.0.bb b/recipes/qt4/qt4-embedded-gles_4.6.0.bb
index 40235e794b..3b3ea153f1 100644
--- a/recipes/qt4/qt4-embedded-gles_4.6.0.bb
+++ b/recipes/qt4/qt4-embedded-gles_4.6.0.bb
@@ -10,8 +10,3 @@ require qt-4.6.0.inc
FILESPATHPKG .= ":qt4-embedded-${PV}:qt4-embedded"
DEPENDS += "virtual/egl"
-
-
-
-SRC_URI[md5sum] = "2a7b5126f2450d8525af355fc4c12ad6"
-SRC_URI[sha256sum] = "55259c813324f6383cbd441aa2f23e01c320b6d63fbe3b5d52a7715055d28589"
diff --git a/recipes/qt4/qt4-embedded-gles_4.6.2.bb b/recipes/qt4/qt4-embedded-gles_4.6.2.bb
index 05299381db..20d4f27c11 100644
--- a/recipes/qt4/qt4-embedded-gles_4.6.2.bb
+++ b/recipes/qt4/qt4-embedded-gles_4.6.2.bb
@@ -10,8 +10,3 @@ require qt-${PV}.inc
FILESPATHPKG .= ":qt4-embedded-${PV}:qt4-embedded"
DEPENDS += "virtual/egl"
-
-
-
-SRC_URI[md5sum] = "eb651ee4b157c01696aa56777fc6e0e5"
-SRC_URI[sha256sum] = "176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae"
diff --git a/recipes/qt4/qt4-embedded_4.6.0.bb b/recipes/qt4/qt4-embedded_4.6.0.bb
index 5590cb8589..3604521ab6 100644
--- a/recipes/qt4/qt4-embedded_4.6.0.bb
+++ b/recipes/qt4/qt4-embedded_4.6.0.bb
@@ -3,7 +3,3 @@ require qt4-embedded.inc
PR = "${INC_PR}.0"
require qt-4.6.0.inc
-
-
-SRC_URI[md5sum] = "2a7b5126f2450d8525af355fc4c12ad6"
-SRC_URI[sha256sum] = "55259c813324f6383cbd441aa2f23e01c320b6d63fbe3b5d52a7715055d28589"
diff --git a/recipes/qt4/qt4-embedded_4.6.2.bb b/recipes/qt4/qt4-embedded_4.6.2.bb
index 406314c58a..13f3f00edf 100644
--- a/recipes/qt4/qt4-embedded_4.6.2.bb
+++ b/recipes/qt4/qt4-embedded_4.6.2.bb
@@ -5,7 +5,3 @@ PR = "${INC_PR}.1"
QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
require qt-${PV}.inc
-
-
-SRC_URI[md5sum] = "eb651ee4b157c01696aa56777fc6e0e5"
-SRC_URI[sha256sum] = "176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae"
diff --git a/recipes/qt4/qt4-x11-free-gles_4.6.0.bb b/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
index 106502630d..dfd53e53a9 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
@@ -14,8 +14,3 @@ FILESPATHPKG .= ":qt4-x11-free-${PV}:qt4-x11-free"
DEPENDS += "virtual/egl"
PROVIDES += "qt4-x11-free"
-
-
-
-SRC_URI[md5sum] = "2a7b5126f2450d8525af355fc4c12ad6"
-SRC_URI[sha256sum] = "55259c813324f6383cbd441aa2f23e01c320b6d63fbe3b5d52a7715055d28589"
diff --git a/recipes/qt4/qt4-x11-free-gles_4.6.2.bb b/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
index dc87d7890e..a1b4e877b1 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.6.2.bb
@@ -14,8 +14,3 @@ FILESPATHPKG .= ":qt4-x11-free-${PV}:qt4-x11-free"
DEPENDS += "virtual/egl"
PROVIDES += "qt4-x11-free"
-
-
-
-SRC_URI[md5sum] = "eb651ee4b157c01696aa56777fc6e0e5"
-SRC_URI[sha256sum] = "176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae"
diff --git a/recipes/qt4/qt4-x11-free_4.6.0.bb b/recipes/qt4/qt4-x11-free_4.6.0.bb
index 36fb0cd0f6..df3462a7c8 100644
--- a/recipes/qt4/qt4-x11-free_4.6.0.bb
+++ b/recipes/qt4/qt4-x11-free_4.6.0.bb
@@ -7,8 +7,3 @@ QT_CONFIG_FLAGS += " \
-no-embedded \
-xrandr \
-x11"
-
-
-
-SRC_URI[md5sum] = "2a7b5126f2450d8525af355fc4c12ad6"
-SRC_URI[sha256sum] = "55259c813324f6383cbd441aa2f23e01c320b6d63fbe3b5d52a7715055d28589"
diff --git a/recipes/qt4/qt4-x11-free_4.6.2.bb b/recipes/qt4/qt4-x11-free_4.6.2.bb
index a11809fa8e..53efd7c8bb 100644
--- a/recipes/qt4/qt4-x11-free_4.6.2.bb
+++ b/recipes/qt4/qt4-x11-free_4.6.2.bb
@@ -9,8 +9,3 @@ QT_CONFIG_FLAGS += " \
-no-embedded \
-xrandr \
-x11"
-
-
-
-SRC_URI[md5sum] = "eb651ee4b157c01696aa56777fc6e0e5"
-SRC_URI[sha256sum] = "176f51ddb06dce67ab4b2efc6b327dc21ed8f764c5d97acc15ff1f907c2affae"