aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-02 07:51:36 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-02 07:51:36 +0000
commit8f61b0343b6c56644fdaa8fa3e84e1c29d3f47b9 (patch)
tree9ab1fe4676cc2f3c97706891dcdbf382b8c729c6 /recipes/qt4
parentb6f983eff85d91dd1015170d7d338c07e22701ef (diff)
downloadopenembedded-8f61b0343b6c56644fdaa8fa3e84e1c29d3f47b9.tar.gz
qt4-tools-native: set LFLAGS to pick up zlib from staging
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/files/configure-lflags.patch13
-rw-r--r--recipes/qt4/qt4-tools-native.inc3
-rw-r--r--recipes/qt4/qt4-tools-native_4.4.3.bb2
-rw-r--r--recipes/qt4/qt4-tools-native_4.5.0.bb2
4 files changed, 17 insertions, 3 deletions
diff --git a/recipes/qt4/files/configure-lflags.patch b/recipes/qt4/files/configure-lflags.patch
new file mode 100644
index 0000000000..df195494ee
--- /dev/null
+++ b/recipes/qt4/files/configure-lflags.patch
@@ -0,0 +1,13 @@
+Index: qtopia-core-opensource-src-4.3.3/configure
+===================================================================
+--- qtopia-core-opensource-src-4.3.3.orig/configure 2008-01-14 08:53:51.000000000 +0000
++++ qtopia-core-opensource-src-4.3.3/configure 2008-01-14 08:54:07.000000000 +0000
+@@ -447,7 +447,7 @@
+ # initalize variables
+ #-------------------------------------------------------------------------------
+
+-SYSTEM_VARIABLES="CC CXX CFLAGS CXXFLAGS LDFLAGS"
++SYSTEM_VARIABLES="CC CXX CFLAGS CXXFLAGS LDFLAGS LFLAGS"
+ for varname in $SYSTEM_VARIABLES; do
+ cmd=`echo \
+ 'if [ -n "\$'${varname}'" ]; then
diff --git a/recipes/qt4/qt4-tools-native.inc b/recipes/qt4/qt4-tools-native.inc
index fe2f94a6d8..df5afd3c15 100644
--- a/recipes/qt4/qt4-tools-native.inc
+++ b/recipes/qt4/qt4-tools-native.inc
@@ -8,6 +8,7 @@ LICENSE = "GPL"
inherit native
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://configure-lflags.patch;patch=1 \
file://qt-config.patch;patch=1 \
file://g++.conf \
file://linux.conf"
@@ -29,7 +30,7 @@ EXTRA_OECONF = "-prefix ${prefix} \
EXTRA_OEMAKE = " "
do_configure() {
- echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
+ echo yes | LFLAGS="-L${STAGING_LIBDIR_NATIVE}" ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
}
TOBUILD = "\
diff --git a/recipes/qt4/qt4-tools-native_4.4.3.bb b/recipes/qt4/qt4-tools-native_4.4.3.bb
index 8a8d46fb8d..ef86db4703 100644
--- a/recipes/qt4/qt4-tools-native_4.4.3.bb
+++ b/recipes/qt4/qt4-tools-native_4.4.3.bb
@@ -1,2 +1,2 @@
require qt4-tools-native.inc
-PR = "r2"
+PR = "r3"
diff --git a/recipes/qt4/qt4-tools-native_4.5.0.bb b/recipes/qt4/qt4-tools-native_4.5.0.bb
index 6e5474be31..ab633149ba 100644
--- a/recipes/qt4/qt4-tools-native_4.5.0.bb
+++ b/recipes/qt4/qt4-tools-native_4.5.0.bb
@@ -1,5 +1,5 @@
require qt4-tools-native.inc
-PR = "r0"
+PR = "r1"
DEFAULT_PREFERENCE = "-1"
TOBUILD := "src/tools/bootstrap ${TOBUILD}"