summaryrefslogtreecommitdiffstats
path: root/recipes/qt4
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-08-10 06:33:31 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-10 06:49:52 +0200
commitf20d7d2a7e87b6c9fa8f368cce8813188c80f00c (patch)
tree4d1799b5982366ab8c1a57b999972b5238f1f963 /recipes/qt4
parent96efe18731e6dddf5fedbe90478fcf9565155081 (diff)
downloadopenembedded-f20d7d2a7e87b6c9fa8f368cce8813188c80f00c.tar.gz
qt4: Hack out the pg_config invocation on configure
Currently the configure script of Qt is invoking pg_config which is a native application and not staged. Even though we pass the directory with the header files we will fail the postgres test as pg_config from the host will tell us something about /usr/include. There is no need for us to check pg_config, hack it out.
Diffstat (limited to 'recipes/qt4')
-rw-r--r--recipes/qt4/files/hack-out-pg_config.patch30
-rw-r--r--recipes/qt4/qt4-embedded_4.5.2.bb3
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.5.2.bb1
-rw-r--r--recipes/qt4/qt4-x11-free_4.5.2.bb1
4 files changed, 34 insertions, 1 deletions
diff --git a/recipes/qt4/files/hack-out-pg_config.patch b/recipes/qt4/files/hack-out-pg_config.patch
new file mode 100644
index 0000000000..2231adf0c7
--- /dev/null
+++ b/recipes/qt4/files/hack-out-pg_config.patch
@@ -0,0 +1,30 @@
+Hack to not use the pg_config of the host system which will add /usr/include
+
+pg_config is a native binary so using that when cross compiling
+will always fail. The commented out fix would do, but for OE
+our -platform and -xplatform is the same so we are actually not
+really cross compiling. Just comment out the test, we are passing
+the location to the postgres headers and if they are okay we
+will padd.
+
+
+
+Index: qt-embedded-linux-opensource-src-4.5.2/configure
+===================================================================
+--- qt-embedded-linux-opensource-src-4.5.2.orig/configure 2009-08-10 03:03:04.000000000 +0200
++++ qt-embedded-linux-opensource-src-4.5.2/configure 2009-08-10 03:58:11.000000000 +0200
+@@ -4401,10 +4402,10 @@
+ ;;
+ psql)
+ if [ "$CFG_SQL_psql" != "no" ]; then
+- if "$WHICH" pg_config >/dev/null 2>&1; then
+- QT_CFLAGS_PSQL=`pg_config --includedir 2>/dev/null`
+- QT_LFLAGS_PSQL=`pg_config --libdir 2>/dev/null`
+- fi
++# if [ "$QT_CROSS_COMPILE" = "no" ] && "$WHICH" pg_config >/dev/null 2>&1; then
++# QT_CFLAGS_PSQL=`pg_config --includedir 2>/dev/null`
++# QT_LFLAGS_PSQL=`pg_config --libdir 2>/dev/null`
++# fi
+ [ -z "$QT_CFLAGS_PSQL" ] || QT_CFLAGS_PSQL="-I$QT_CFLAGS_PSQL"
+ [ -z "$QT_LFLAGS_PSQL" ] || QT_LFLAGS_PSQL="-L$QT_LFLAGS_PSQL"
+ if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/unix/psql "PostgreSQL" $QT_LFLAGS_PSQL $L_FLAGS $QT_CFLAGS_PSQL $I_FLAGS $l_FLAGS $MAC_ARCHS_COMMANDLINE; then
diff --git a/recipes/qt4/qt4-embedded_4.5.2.bb b/recipes/qt4/qt4-embedded_4.5.2.bb
index d94bc4862d..c941b25dd4 100644
--- a/recipes/qt4/qt4-embedded_4.5.2.bb
+++ b/recipes/qt4/qt4-embedded_4.5.2.bb
@@ -3,4 +3,5 @@ require qt4-embedded.inc
PR = "${INC_PR}.1"
LICENSE = "LGPLv2.1 GPLv3"
-SRC_URI += "file://0010-no-simpledecoration-example.patch;patch=1"
+SRC_URI += "file://0010-no-simpledecoration-example.patch;patch=1 \
+ file://hack-out-pg_config.patch;patch=1"
diff --git a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
index 944378d0dd..cd81841269 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
@@ -12,6 +12,7 @@ PR = "${INC_PR}.3"
DEPENDS += "virtual/egl"
#SRC_URI += "file://sgx-hack.patch;patch=1"
+SRC_URI += "file://hack-out-pg_config.patch;patch=1"
export EXTRA_QMAKE_MUNGE = " glmunge "
diff --git a/recipes/qt4/qt4-x11-free_4.5.2.bb b/recipes/qt4/qt4-x11-free_4.5.2.bb
index 0289f211b4..09f63363f0 100644
--- a/recipes/qt4/qt4-x11-free_4.5.2.bb
+++ b/recipes/qt4/qt4-x11-free_4.5.2.bb
@@ -2,3 +2,4 @@ require qt4-x11-free.inc
LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.2"
+SRC_URI += "file://hack-out-pg_config.patch;patch=1"