summaryrefslogtreecommitdiffstats
path: root/recipes/quake
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-24 13:01:00 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:54:52 -0700
commit6fe7cef27069415f2eba36bc640cf59013d4979b (patch)
treeb0cb8845ddc6b8bcffc50e08a2eeae98e049be98 /recipes/quake
parentbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (diff)
downloadopenembedded-6fe7cef27069415f2eba36bc640cf59013d4979b.tar.gz
Make the do_patch apply=yes param implicit if extension is .diff/.patch
For .diff/.patch you need to apply manually, you can specify apply=no. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/quake')
-rw-r--r--recipes/quake/quake1_0.0.1.bb8
-rw-r--r--recipes/quake/quake2_svn.bb2
-rw-r--r--recipes/quake/quake3-pandora-gles_git.bb2
-rw-r--r--recipes/quake/sdlquake_1.0.9.bb2
4 files changed, 7 insertions, 7 deletions
diff --git a/recipes/quake/quake1_0.0.1.bb b/recipes/quake/quake1_0.0.1.bb
index ea07ba4730..0fc11015ba 100644
--- a/recipes/quake/quake1_0.0.1.bb
+++ b/recipes/quake/quake1_0.0.1.bb
@@ -7,10 +7,10 @@ PR = "r2"
SRC_URI = "http://mirror1.pdaXrom.org/rc9/src/quake1src.tar.bz2;name=archive \
http://mirror1.pdaxrom.org/source/src/pak0.tar.gz;name=pak0 \
- file://Makefile.patch;apply=yes \
- file://cl_parse.c.patch;apply=yes \
- file://vid_sdl.c.patch;apply=yes \
- file://host.c.patch;apply=yes"
+ file://Makefile.patch \
+ file://cl_parse.c.patch \
+ file://vid_sdl.c.patch \
+ file://host.c.patch"
S = "${WORKDIR}/quake1src"
diff --git a/recipes/quake/quake2_svn.bb b/recipes/quake/quake2_svn.bb
index abfb2f704a..ff01b065ae 100644
--- a/recipes/quake/quake2_svn.bb
+++ b/recipes/quake/quake2_svn.bb
@@ -8,7 +8,7 @@ PV = "0.16.1+svnr${SRCPV}"
PR = "r1"
SRC_URI = "svn://svn.icculus.org/quake2/;module=trunk \
- file://quake2-arm.patch;apply=yes"
+ file://quake2-arm.patch"
S = "${WORKDIR}/trunk"
diff --git a/recipes/quake/quake3-pandora-gles_git.bb b/recipes/quake/quake3-pandora-gles_git.bb
index 16f0f0b805..fe4d37e9d0 100644
--- a/recipes/quake/quake3-pandora-gles_git.bb
+++ b/recipes/quake/quake3-pandora-gles_git.bb
@@ -8,7 +8,7 @@ PV = "0.0"
DEPENDS = "virtual/libsdl libgles-omap3"
SRC_URI = "git://github.com/Cpasjuste/quake3_pandora_gles.git;branch=master;protocol=git \
- file://quake3_makefile.patch;apply=yes \
+ file://quake3_makefile.patch \
"
S = "${WORKDIR}/git"
diff --git a/recipes/quake/sdlquake_1.0.9.bb b/recipes/quake/sdlquake_1.0.9.bb
index f621f0f483..bfaf2e8f8c 100644
--- a/recipes/quake/sdlquake_1.0.9.bb
+++ b/recipes/quake/sdlquake_1.0.9.bb
@@ -5,7 +5,7 @@ DEPENDS = "libsdl-x11 libsdl-mixer libsdl-net zlib libxau"
LICENSE = "GPL"
SRC_URI = "http://www.libsdl.org/projects/quake/src/sdlquake-${PV}.tar.gz \
- file://sdlquake-no-x86-asm.diff;apply=yes \
+ file://sdlquake-no-x86-asm.diff \
"
inherit autotools