aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/r
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/r
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/r')
-rw-r--r--recipes/r/r-native_2.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/r/r-native_2.0.0.bb b/recipes/r/r-native_2.0.0.bb
new file mode 100644
index 0000000000..d9360dfaef
--- /dev/null
+++ b/recipes/r/r-native_2.0.0.bb
@@ -0,0 +1,20 @@
+DEPENDS = "ncurses-native perl-native"
+
+SRC_URI = "http://www.stats.bris.ac.uk/R/src/base/R-2/R-${PV}.tar.gz"
+
+EXTRA_OECONF = "--without-x --without-readline --without-gnome --without-tcltk --without-libpng \
+ --without-jpeglib"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/R-${PV}"
+
+S = "${WORKDIR}/R-${PV}"
+
+inherit autotools native
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ install -m 0755 ${S}/bin/R ${STAGING_BINDIR}/R
+}