aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rdiff-backup
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rdiff-backup
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rdiff-backup')
-rw-r--r--recipes/rdiff-backup/rdiff-backup.inc41
-rw-r--r--recipes/rdiff-backup/rdiff-backup_1.0.4.bb2
-rw-r--r--recipes/rdiff-backup/rdiff-backup_1.1.5.bb5
3 files changed, 48 insertions, 0 deletions
diff --git a/recipes/rdiff-backup/rdiff-backup.inc b/recipes/rdiff-backup/rdiff-backup.inc
new file mode 100644
index 0000000000..d268736df8
--- /dev/null
+++ b/recipes/rdiff-backup/rdiff-backup.inc
@@ -0,0 +1,41 @@
+DESCRIPTION = "A python application that backs up one directory to \
+another, possibly over a network. It combines the best features of a \
+mirror and an incremental backup. The target directory ends up a copy \
+of the source directory, but extra reverse diffs are stored in a \
+special subdirectory of that target directory, so you can still \
+recover files lost some time ago. It is also able to preserve \
+subdirectories, hard links, dev files, permissions, uid/gid \
+ownership, modification times, extended attributes, acls, and \
+resource forks."
+HOMEPAGE = "http://www.nongnu.org/rdiff-backup/"
+SECTION = "network"
+LICENSE = "GPL"
+DEPENDS = "librsync"
+RDEPENDS_${PN} = "zlib python-re python-io python-lang python-datetime \
+ python-pickle python-shell python-compression python-unixadmin \
+ python-netclient"
+
+SRC_URI = "http://savannah.nongnu.org/download/rdiff-backup/rdiff-backup-${PV}.tar.gz"
+
+inherit distutils
+
+#
+# Without this the python interpreter path points to the staging area.
+#
+do_compile() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py build --executable=${bindir}/python || \
+ oefatal "python setup.py build execution failed."
+}
+
+#
+# The default do_install sets install-data to ${D}/${datadir} which
+# ends up with documentation in /usr/share/share/... instead of
+# /usr/share/... Modify the install data directory here to get it
+# into the correct place.
+#
+do_install() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py install --prefix=${D}/${prefix} --install-data=${D}/${prefix} || \
+ oefatal "python setup.py install execution failed."
+}
diff --git a/recipes/rdiff-backup/rdiff-backup_1.0.4.bb b/recipes/rdiff-backup/rdiff-backup_1.0.4.bb
new file mode 100644
index 0000000000..836363ddf7
--- /dev/null
+++ b/recipes/rdiff-backup/rdiff-backup_1.0.4.bb
@@ -0,0 +1,2 @@
+require rdiff-backup.inc
+PR = "r1"
diff --git a/recipes/rdiff-backup/rdiff-backup_1.1.5.bb b/recipes/rdiff-backup/rdiff-backup_1.1.5.bb
new file mode 100644
index 0000000000..6b67289b0b
--- /dev/null
+++ b/recipes/rdiff-backup/rdiff-backup_1.1.5.bb
@@ -0,0 +1,5 @@
+require rdiff-backup.inc
+PR = "r1"
+
+# 1.1.x added the use of sha which we get from python-crypt
+RDEPENDS_${PN} += "python-crypt"