aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/readline/readline_4.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/readline/readline_4.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/readline/readline_4.3.bb')
-rw-r--r--recipes/readline/readline_4.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/readline/readline_4.3.bb b/recipes/readline/readline_4.3.bb
new file mode 100644
index 0000000000..a2420c57e4
--- /dev/null
+++ b/recipes/readline/readline_4.3.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
+command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes \
+additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those \
+lines, and perform csh-like history expansion on previous commands."
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS += "ncurses"
+RPROVIDES_${PN} += "readline"
+LEAD_SONAME = "libreadline.so"
+PR = "r3"
+
+SRC_URI = "${GNU_MIRROR}/readline/readline-${PV}.tar.gz \
+ file://shlink-termcap.patch;patch=1 \
+ file://acinclude.m4"
+S = "${WORKDIR}/readline-${PV}"
+
+inherit autotools
+
+do_configure () {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+ autotools_do_configure
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install () {
+ autotools_do_install
+ # Make install doesn't properly install these
+ oe_libinstall -so -C shlib libhistory ${D}${libdir}
+ oe_libinstall -so -C shlib libreadline ${D}${libdir}
+}