summaryrefslogtreecommitdiffstats
path: root/recipes/readline
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-03-28 00:16:17 -0700
committerKhem Raj <raj.khem@gmail.com>2010-03-28 00:16:17 -0700
commit2e551bcaf420a55759df977b5bcc1d6c06cece25 (patch)
tree9c5ef9eda77c3347e8f7db6a82bba617564328cd /recipes/readline
parent6675bb93144399106efb830eee972b7ec9f4b391 (diff)
downloadopenembedded-2e551bcaf420a55759df977b5bcc1d6c06cece25.tar.gz
readline: Use BBCLASSEXTEND for native recipe.
* Get rid of do_stage. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/readline')
-rw-r--r--recipes/readline/readline-native_4.3.bb4
-rw-r--r--recipes/readline/readline-native_5.2.bb4
-rw-r--r--recipes/readline/readline_4.3.bb8
-rw-r--r--recipes/readline/readline_5.2.bb9
4 files changed, 7 insertions, 18 deletions
diff --git a/recipes/readline/readline-native_4.3.bb b/recipes/readline/readline-native_4.3.bb
deleted file mode 100644
index c3ce970b4c..0000000000
--- a/recipes/readline/readline-native_4.3.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require readline_${PV}.bb
-inherit native
-DEPENDS = "ncurses-native"
-FILESPATH = "${FILE_DIRNAME}/readline-${PV}:${FILE_DIRNAME}/readline:${FILE_DIRNAME}/files:${FILE_DIRNAME}"
diff --git a/recipes/readline/readline-native_5.2.bb b/recipes/readline/readline-native_5.2.bb
deleted file mode 100644
index c3ce970b4c..0000000000
--- a/recipes/readline/readline-native_5.2.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require readline_${PV}.bb
-inherit native
-DEPENDS = "ncurses-native"
-FILESPATH = "${FILE_DIRNAME}/readline-${PV}:${FILE_DIRNAME}/readline:${FILE_DIRNAME}/files:${FILE_DIRNAME}"
diff --git a/recipes/readline/readline_4.3.bb b/recipes/readline/readline_4.3.bb
index a2420c57e4..12d6bb4470 100644
--- a/recipes/readline/readline_4.3.bb
+++ b/recipes/readline/readline_4.3.bb
@@ -8,7 +8,7 @@ LICENSE = "GPLv2"
DEPENDS += "ncurses"
RPROVIDES_${PN} += "readline"
LEAD_SONAME = "libreadline.so"
-PR = "r3"
+PR = "r4"
SRC_URI = "${GNU_MIRROR}/readline/readline-${PV}.tar.gz \
file://shlink-termcap.patch;patch=1 \
@@ -22,13 +22,11 @@ do_configure () {
autotools_do_configure
}
-do_stage() {
- autotools_stage_all
-}
-
do_install () {
autotools_do_install
# Make install doesn't properly install these
oe_libinstall -so -C shlib libhistory ${D}${libdir}
oe_libinstall -so -C shlib libreadline ${D}${libdir}
}
+NATIVE_INSTALL_WORKS = 1
+BBCLASSEXTEND = "native"
diff --git a/recipes/readline/readline_5.2.bb b/recipes/readline/readline_5.2.bb
index b7071167bc..0e8de3629b 100644
--- a/recipes/readline/readline_5.2.bb
+++ b/recipes/readline/readline_5.2.bb
@@ -8,7 +8,7 @@ LICENSE = "GPLv2"
DEPENDS += "ncurses"
RPROVIDES_${PN} += "readline"
LEAD_SONAME = "libreadline.so"
-PR = "r5"
+PR = "r6"
SRC_URI = "\
ftp://ftp.gnu.org/gnu/readline/readline-${PV}.tar.gz \
@@ -25,13 +25,12 @@ do_configure () {
autotools_do_configure
}
-do_stage() {
- autotools_stage_all
-}
-
do_install () {
autotools_do_install
# Make install doesn't properly install these
oe_libinstall -so -C shlib libhistory ${D}${libdir}
oe_libinstall -so -C shlib libreadline ${D}${libdir}
}
+NATIVE_INSTALL_WORKS = 1
+BBCLASSEXTEND = "native"
+