aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/realpath/realpath_1.15.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-28 19:44:13 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-28 19:44:13 -0700
commit4daefb7e3904ed50a979e44f704e95d966237cda (patch)
treee3d50066c5065d409d4cfcd8cf1a2480d1c536a5 /recipes/realpath/realpath_1.15.bb
parente614547fafed0843bb6a4ad25abe457993d9f463 (diff)
downloadopenembedded-4daefb7e3904ed50a979e44f704e95d966237cda.tar.gz
realpath: Add recipe for version 1.15
* Rename files to realpath-1.10 as it only has patches relevant to 1.10 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/realpath/realpath_1.15.bb')
-rw-r--r--recipes/realpath/realpath_1.15.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/realpath/realpath_1.15.bb b/recipes/realpath/realpath_1.15.bb
new file mode 100644
index 0000000000..4ac6b4c940
--- /dev/null
+++ b/recipes/realpath/realpath_1.15.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Return the canonicalized absolute pathname"
+SECTION = "utility"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
+ file://fix-common-mk.patch \
+ file://no-po4a.patch \
+ file://remove-nls.patch \
+ "
+
+CFLAGS += "-DVERSION=${PV}"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -p -m 0755 ${S}/src/_build/realpath ${D}${bindir}
+}
+
+SRC_URI[realpath.md5sum] = "3351ce6e3d0ce255641c8ca9216a8638"
+SRC_URI[realpath.sha256sum] = "b3d11cec375145ea60663e6fe54727c70a0e86c18f40bddac2a89b635cc1531f"