aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/realpath
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-28 19:44:13 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-28 19:44:13 -0700
commit4daefb7e3904ed50a979e44f704e95d966237cda (patch)
treee3d50066c5065d409d4cfcd8cf1a2480d1c536a5 /recipes/realpath
parente614547fafed0843bb6a4ad25abe457993d9f463 (diff)
downloadopenembedded-4daefb7e3904ed50a979e44f704e95d966237cda.tar.gz
realpath: Add recipe for version 1.15
* Rename files to realpath-1.10 as it only has patches relevant to 1.10 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/realpath')
-rw-r--r--recipes/realpath/realpath-1.10/makefile.patch (renamed from recipes/realpath/files/makefile.patch)0
-rw-r--r--recipes/realpath/realpath-1.15/fix-common-mk.patch38
-rw-r--r--recipes/realpath/realpath-1.15/no-po4a.patch11
-rw-r--r--recipes/realpath/realpath-1.15/remove-nls.patch27
-rw-r--r--recipes/realpath/realpath_1.15.bb20
5 files changed, 96 insertions, 0 deletions
diff --git a/recipes/realpath/files/makefile.patch b/recipes/realpath/realpath-1.10/makefile.patch
index d97ba59778..d97ba59778 100644
--- a/recipes/realpath/files/makefile.patch
+++ b/recipes/realpath/realpath-1.10/makefile.patch
diff --git a/recipes/realpath/realpath-1.15/fix-common-mk.patch b/recipes/realpath/realpath-1.15/fix-common-mk.patch
new file mode 100644
index 0000000000..3556d04b2e
--- /dev/null
+++ b/recipes/realpath/realpath-1.15/fix-common-mk.patch
@@ -0,0 +1,38 @@
+Index: realpath-1.15/common.mk
+===================================================================
+--- realpath-1.15.orig/common.mk 2010-06-28 17:26:17.611275002 -0700
++++ realpath-1.15/common.mk 2010-06-28 17:31:40.151275002 -0700
+@@ -8,17 +8,15 @@
+
+ override PACKAGE := realpath
+
+-PATH := /usr/bin:/usr/sbin:/bin:/sbin:$(PATH)
+-
+ # build abstraction
+-install_file := install -p -o root -g root -m 644
+-install_script := install -p -o root -g root -m 755
+-install_dir := install -d -o root -g root -m 755
++install_file := install -p -m 644
++install_script := install -p -m 755
++install_dir := install -d -m 755
+ install_link := ln -sf
+ compress := gzip -9f
+
+-prefix := /usr
+-etcdir := /etc/$(PACKAGE)
++prefix := $(prefix)
++etcdir := $(sysconfdir)/$(PACKAGE)
+ bindir := $(prefix)/bin
+ sbindir := $(prefix)/sbin
+ mandir := $(prefix)/share/man
+@@ -33,8 +31,8 @@
+ webcgidir := $(prefix)/lib/cgi-bin
+ applicationsdir := $(prefix)/share/applications
+
+-PERL := /usr/bin/perl
+-CC := gcc
++PERL := perl
++CC := $(CC)
+ CFLAGS = -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
+ LDFLAGS :=
+ LIBS :=
diff --git a/recipes/realpath/realpath-1.15/no-po4a.patch b/recipes/realpath/realpath-1.15/no-po4a.patch
new file mode 100644
index 0000000000..26c9a06145
--- /dev/null
+++ b/recipes/realpath/realpath-1.15/no-po4a.patch
@@ -0,0 +1,11 @@
+Index: realpath-1.15/po/Makefile
+===================================================================
+--- realpath-1.15.orig/po/Makefile 2010-06-28 17:22:08.561275001 -0700
++++ realpath-1.15/po/Makefile 2010-06-28 17:22:17.421275001 -0700
+@@ -4,5 +4,5 @@
+ #
+
+ ALL_TARGET=
+-SUBDIRS=bin man
++SUBDIRS=bin
+ include ../common.mk
diff --git a/recipes/realpath/realpath-1.15/remove-nls.patch b/recipes/realpath/realpath-1.15/remove-nls.patch
new file mode 100644
index 0000000000..e2910e1a2b
--- /dev/null
+++ b/recipes/realpath/realpath-1.15/remove-nls.patch
@@ -0,0 +1,27 @@
+Index: realpath-1.15/src/realpath.c
+===================================================================
+--- realpath-1.15.orig/src/realpath.c 2010-06-28 17:24:05.591275001 -0700
++++ realpath-1.15/src/realpath.c 2010-06-28 17:24:52.731275001 -0700
+@@ -23,9 +23,8 @@
+ #include <errno.h>
+ #include <getopt.h>
+ #include <stdarg.h>
+-#include <libintl.h>
+
+-#define _(String) gettext (String)
++#define _(String) (String)
+
+ static char *stripdir(char * dir, char *buf, int maxlen);
+
+@@ -115,11 +114,6 @@
+
+ myname = ( p = strchr(argv[0], '/') ) ? p+1 : argv[0];
+
+- setlocale(LC_ALL, "");
+- bindtextdomain(PACKAGE, LOCALEDIR);
+- textdomain(PACKAGE);
+-
+-
+ parse_options(argc, argv);
+
+ while (optind < argc) {
diff --git a/recipes/realpath/realpath_1.15.bb b/recipes/realpath/realpath_1.15.bb
new file mode 100644
index 0000000000..4ac6b4c940
--- /dev/null
+++ b/recipes/realpath/realpath_1.15.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Return the canonicalized absolute pathname"
+SECTION = "utility"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
+ file://fix-common-mk.patch \
+ file://no-po4a.patch \
+ file://remove-nls.patch \
+ "
+
+CFLAGS += "-DVERSION=${PV}"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -p -m 0755 ${S}/src/_build/realpath ${D}${bindir}
+}
+
+SRC_URI[realpath.md5sum] = "3351ce6e3d0ce255641c8ca9216a8638"
+SRC_URI[realpath.sha256sum] = "b3d11cec375145ea60663e6fe54727c70a0e86c18f40bddac2a89b635cc1531f"