aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/realpath
diff options
context:
space:
mode:
authorMartyn Welch <martyn.welch@ge.com>2010-03-21 23:34:46 +0000
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2010-03-30 14:19:59 +0200
commitc5014e1b9f9a321793b2b173270e75770f7b7fce (patch)
tree7a94ba3d0f3a041b16991dc18f3bb03ad8817df4 /recipes/realpath
parentba9d4c218163404167cde22fafbf362a2f128191 (diff)
downloadopenembedded-c5014e1b9f9a321793b2b173270e75770f7b7fce.tar.gz
realpath: added 1.10
The package contains a small utility realpath, which converts each pathname argument to an absolute pathname, which has no components that are symbolic links or the special . or .. directory entries. This utility provides mostly the same functionality as `/bin/readlink -f' in the coreutils package. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes/realpath')
-rw-r--r--recipes/realpath/files/makefile.patch12
-rw-r--r--recipes/realpath/realpath_1.10.bb17
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes/realpath/files/makefile.patch b/recipes/realpath/files/makefile.patch
new file mode 100644
index 0000000000..d97ba59778
--- /dev/null
+++ b/recipes/realpath/files/makefile.patch
@@ -0,0 +1,12 @@
+diff -urN realpath-1.10.orig/Makefile realpath-1.10/Makefile
+--- realpath-1.10.orig/Makefile 2009-07-28 16:04:11.000000000 +0100
++++ realpath-1.10/Makefile 2009-07-28 16:08:44.000000000 +0100
+@@ -3,7 +3,7 @@
+ # "@(#)realpath:$Id: Makefile,v 1.30 2006-05-07 19:41:41 robert Exp $"
+ #
+
+-VERSION = $(shell dpkg-parsechangelog | sed -ne 's/^Version: *//p')
++#VERSION = $(shell dpkg-parsechangelog | sed -ne 's/^Version: *//p')
+
+ CC = gcc
+ CFLAGS = -Wall -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"'
diff --git a/recipes/realpath/realpath_1.10.bb b/recipes/realpath/realpath_1.10.bb
new file mode 100644
index 0000000000..4833740907
--- /dev/null
+++ b/recipes/realpath/realpath_1.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Return the canonicalized absolute pathname"
+SECTION = "utility"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/r/realpath/realpath_${PV}.tar.gz;name=realpath \
+ file://makefile.patch;patch=1"
+
+SRC_URI[realpath.md5sum] = "1f2b2bceaacadf79162a9cbb5956c3b6"
+SRC_URI[realpath.sha256sum] = "72199f9c11d1f9a36b3b9693988b558a167def6b88fa146ea6a7f7223f96c535"
+
+CFLAGS += "-DVERSION=${PV}"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -p -m 0755 ${S}/realpath ${D}${bindir}
+}