summaryrefslogtreecommitdiffstats
path: root/recipes/redboot-utils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/redboot-utils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/redboot-utils')
-rw-r--r--recipes/redboot-utils/fconfig_20060419.bb14
-rw-r--r--recipes/redboot-utils/fis_1.0.bb14
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/redboot-utils/fconfig_20060419.bb b/recipes/redboot-utils/fconfig_20060419.bb
new file mode 100644
index 0000000000..561718f9b2
--- /dev/null
+++ b/recipes/redboot-utils/fconfig_20060419.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Tool to edit the Redboot config from userspace"
+PR = "r1"
+
+SRC_URI = "http://andrzejekiert.ovh.org/software/fconfig/fconfig-20060419.tar.gz"
+
+S = ${WORKDIR}/fconfig
+do_compile() {
+ ${MAKE}
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 755 ${S}/fconfig ${D}/${sbindir}
+}
diff --git a/recipes/redboot-utils/fis_1.0.bb b/recipes/redboot-utils/fis_1.0.bb
new file mode 100644
index 0000000000..e1ac56448b
--- /dev/null
+++ b/recipes/redboot-utils/fis_1.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Tool to edit the Redboot FIS partition layout from userspace"
+PR = "r5"
+
+SRC_URI = "svn://svn.nslu2-linux.org/svnroot/fis;module=trunk;proto=http;rev=6"
+S="${WORKDIR}/trunk"
+
+export CFLAGS += "--std=c99"
+
+do_install() {
+ ${STRIP} ${S}/fis
+
+ install -d ${D}/${sbindir}
+ install -m 755 ${S}/fis ${D}/${sbindir}
+}