aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/redfang
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/redfang
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/redfang')
-rw-r--r--recipes/redfang/files/Makefile.patch18
-rw-r--r--recipes/redfang/redfang.bb22
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes/redfang/files/Makefile.patch b/recipes/redfang/files/Makefile.patch
new file mode 100644
index 0000000000..1810127cf3
--- /dev/null
+++ b/recipes/redfang/files/Makefile.patch
@@ -0,0 +1,18 @@
+--- Makefile 2005-11-23 10:43:27.000000000 -0500
++++ Makefile.new 2005-11-23 10:42:20.000000000 -0500
+@@ -3,12 +3,13 @@
+
+ DEPS=list.h
+
+-LIBS=-lbluetooth -lpthread
++#LIBS=-lbluetooth -lpthread
++LIBS=$(LDFLAGS)
+
+ all: $(EXE)
+
+ $(EXE): $(OBJ) $(DEPS)
+- cc -o $(EXE) $(OBJ) $(LIBS)
++ $(CC) -o $(EXE) $(OBJ) $(LIBS)
+
+ clean:
+ rm -f $(EXE) $(OBJ) *~
diff --git a/recipes/redfang/redfang.bb b/recipes/redfang/redfang.bb
new file mode 100644
index 0000000000..09349ad79e
--- /dev/null
+++ b/recipes/redfang/redfang.bb
@@ -0,0 +1,22 @@
+SECTION = "unknown"
+SRC_URI = "http://packetstormsecurity.org/wireless/redfang.2.5.tar.gz \
+ file://Makefile.patch;patch=1;pnum=0"
+
+DEFAULT_PREFERENCE="-1"
+PV="2.5"
+
+CFLAGS_prepend = "-I${STAGING_INCDIR}/bluetooth"
+
+LDFLAGS_prepend = "-L${STAGING_LIBDIR} -lbluetooth -lpthread "
+
+S = "${WORKDIR}/redfang-2.5"
+LICENSE = "GPL"
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/fang ${D}${bindir}
+}
+