aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/regina-rexx/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/regina-rexx/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/regina-rexx/files')
-rw-r--r--recipes/regina-rexx/files/use-proper-host-tools.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes/regina-rexx/files/use-proper-host-tools.patch b/recipes/regina-rexx/files/use-proper-host-tools.patch
new file mode 100644
index 0000000000..cd0dafcab8
--- /dev/null
+++ b/recipes/regina-rexx/files/use-proper-host-tools.patch
@@ -0,0 +1,48 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- regina-rexx-3.3-r0/Makefile.in~use-proper-host-tools.patch
++++ regina-rexx-3.3-r0/Makefile.in
+@@ -321,8 +321,8 @@
+ # Convert .mts to .mtb
+ #
+ $(MTBFILES): msgcmp$(EXE) $(MTSSRC)
+- ./msgcmp $(MTSSRC)
+- ./rexx $(srcdir)/checkmts.rexx $(srcdir)
++ $(STAGING_BINDIR_NATIVE)/msgcmp-multi-input $(MTSSRC)
++ $(STAGING_BINDIR_NATIVE)/rexx $(srcdir)/checkmts.rexx $(srcdir)
+
+ msgcmp$(EXE): msgcmp.$(OBJ)
+ $(PURIFY) $(CC) $(LINKOPT) -o msgcmp$(EXE) msgcmp.$(OBJ)
+@@ -919,22 +919,22 @@
+ $(INSTALL) -m 644 -c ./de.mtb $(sharedir)/de.mtb
+ $(INSTALL) -m 644 -c ./es.mtb $(sharedir)/es.mtb
+ $(INSTALL) -m 644 -c ./pl.mtb $(sharedir)/pl.mtb
+- $(bindir)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/rexxcps.rexx $(sharedir)/rexxcps.rexx
++ $(STAGING_BINDIR_NATIVE)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/rexxcps.rexx $(sharedir)/rexxcps.rexx
+ -chmod 755 $(sharedir)/rexxcps.rexx
+- $(bindir)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/animal.rexx $(sharedir)/animal.rexx
++ $(STAGING_BINDIR_NATIVE)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/animal.rexx $(sharedir)/animal.rexx
+ -chmod 755 $(sharedir)/animal.rexx
+- $(bindir)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/block.rexx $(sharedir)/block.rexx
++ $(STAGING_BINDIR_NATIVE)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/block.rexx $(sharedir)/block.rexx
+ -chmod 755 $(sharedir)/block.rexx
+- $(bindir)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/dateconv.rexx $(sharedir)/dateconv.rexx
++ $(STAGING_BINDIR_NATIVE)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/dateconv.rexx $(sharedir)/dateconv.rexx
+ -chmod 755 $(sharedir)/dateconv.rexx
+- $(bindir)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/timeconv.rexx $(sharedir)/timeconv.rexx
++ $(STAGING_BINDIR_NATIVE)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/timeconv.rexx $(sharedir)/timeconv.rexx
+ -chmod 755 $(sharedir)/timeconv.rexx
+- $(bindir)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/newstr.rexx $(sharedir)/newstr.rexx
++ $(STAGING_BINDIR_NATIVE)/rexx $(srcdir)/preinst.rexx $(bindir)/rexx $(srcdir)/demo/newstr.rexx $(sharedir)/newstr.rexx
+ -chmod 755 $(sharedir)/newstr.rexx
+
+ installregina:
+ $(INSTALL) -m 755 -c ./regina$(EXE) $(bindir)/regina$(EXE)
+- $(bindir)/rexx $(srcdir)/preinst.rexx $(bindir)/regina $(srcdir)/demo/dynfunc.rexx $(sharedir)/dynfunc.rexx
++ $(STAGING_BINDIR_NATIVE)/rexx $(srcdir)/preinst.rexx $(bindir)/regina $(srcdir)/demo/dynfunc.rexx $(sharedir)/dynfunc.rexx
+ -chmod 755 $(sharedir)/dynfunc.rexx
+
+ installlib: installregina