aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rfkill
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-02-11 10:40:26 +0100
committerKoen Kooi <koen@openembedded.org>2011-02-11 10:41:31 +0100
commit98ceb8ba471f5ac0c9630eddc80471dcba6ef458 (patch)
treeb7611d9259a392dd11369f7b4d615f367aa54e35 /recipes/rfkill
parenta5d1ff6e86270bad2b1e0d997bee7d3752c6fbe9 (diff)
downloadopenembedded-98ceb8ba471f5ac0c9630eddc80471dcba6ef458.tar.gz
rfkill: fix install and remove bogus DEPENDS, it's not using libnl nor pkgconfig(-native)
Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/rfkill')
-rw-r--r--recipes/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch30
-rw-r--r--recipes/rfkill/rfkill_0.4.bb16
2 files changed, 37 insertions, 9 deletions
diff --git a/recipes/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch b/recipes/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch
new file mode 100644
index 0000000000..c6f60d0ede
--- /dev/null
+++ b/recipes/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch
@@ -0,0 +1,30 @@
+From db764080e54f8f998c28ef8dab78da8b8d1d1420 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 11 Feb 2011 10:35:40 +0100
+Subject: [PATCH] rfkill makefile: don't use -t, the OE install wrapper dislikes it
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8d6c700..3652690 100644
+--- a/Makefile
++++ b/Makefile
+@@ -53,10 +53,10 @@ check:
+ install: rfkill rfkill.8.gz
+ @$(NQ) ' INST rfkill'
+ $(Q)$(MKDIR) $(DESTDIR)$(SBINDIR)
+- $(Q)$(INSTALL) -m 755 -t $(DESTDIR)$(SBINDIR) rfkill
++ $(Q)$(INSTALL) -m 755 rfkill $(DESTDIR)$(SBINDIR)
+ @$(NQ) ' INST rfkill.8'
+ $(Q)$(MKDIR) $(DESTDIR)$(MANDIR)/man8/
+- $(Q)$(INSTALL) -m 644 -t $(DESTDIR)$(MANDIR)/man8/ rfkill.8.gz
++ $(Q)$(INSTALL) -m 644 rfkill.8.gz $(DESTDIR)$(MANDIR)/man8/
+
+ clean:
+ $(Q)rm -f rfkill *.o *~ *.gz version.c *-stamp
+--
+1.6.6.1
+
diff --git a/recipes/rfkill/rfkill_0.4.bb b/recipes/rfkill/rfkill_0.4.bb
index 6691049648..d432080a4b 100644
--- a/recipes/rfkill/rfkill_0.4.bb
+++ b/recipes/rfkill/rfkill_0.4.bb
@@ -2,19 +2,17 @@ DESCRIPTION = "rfkill CLI utility"
HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/rfkill"
SECTION = "base"
LICENSE = "BSD"
-PR = "r0"
+PR = "r1"
-DEPENDS = "libnl pkgconfig"
+SRC_URI = "http://wireless.kernel.org/download/${PN}/${P}.tar.bz2 \
+ file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch"
-SRC_URI = "http://wireless.kernel.org/download/${PN}/${P}.tar.bz2"
+SRC_URI[md5sum] = "727892c0fb35c80ee3849fbe89b45350"
+SRC_URI[sha256sum] = "ca10e4827a5f0a36e093aee6ad81b5febf81f8097d7d858889ac51ff364168c1"
do_compile() {
- oe_runmake
+ oe_runmake
}
-
do_install() {
- oe_runmake DESTDIR=${D} install
+ oe_runmake DESTDIR=${D} install
}
-
-SRC_URI[md5sum] = "727892c0fb35c80ee3849fbe89b45350"
-SRC_URI[sha256sum] = "ca10e4827a5f0a36e093aee6ad81b5febf81f8097d7d858889ac51ff364168c1"