aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/robostix/robostix
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/robostix/robostix
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/robostix/robostix')
-rw-r--r--recipes/robostix/robostix/gummake.patch26
-rw-r--r--recipes/robostix/robostix/makefile-rules.patch25
2 files changed, 51 insertions, 0 deletions
diff --git a/recipes/robostix/robostix/gummake.patch b/recipes/robostix/robostix/gummake.patch
new file mode 100644
index 0000000000..0b968592b5
--- /dev/null
+++ b/recipes/robostix/robostix/gummake.patch
@@ -0,0 +1,26 @@
+--- robostix/gumstix/Makefile.orig 2008-03-08 11:37:50.000000000 -0700
++++ robostix/gumstix/Makefile 2008-03-08 11:36:55.000000000 -0700
+@@ -32,10 +32,10 @@
+
+ PWD := $(shell pwd)
+
+-GUMSTIX_BUILDROOT = $(PWD)/../../gumstix-buildroot
+-BUILD_ARM = $(GUMSTIX_BUILDROOT)/build_arm_nofpu
+-KERNELDIR ?= $(wildcard $(BUILD_ARM)/linux-*)
+-CROSS_COMPILE = $(BUILD_ARM)/staging_dir/bin/arm-linux-
++#GUMSTIX_BUILDROOT = $(PWD)/../../gumstix-buildroot
++#BUILD_ARM = $(GUMSTIX_BUILDROOT)/build_arm_nofpu
++#KERNELDIR ?= $(wildcard $(BUILD_ARM)/linux-*)
++#CROSS_COMPILE = $(BUILD_ARM)/staging_dir/bin/arm-linux-
+
+ default: svn-version.h user-app kernel-module
+
+@@ -47,7 +47,7 @@
+ user-app: robostix sertest
+
+ TARGET_ARCH=-Os -march=armv5te -mtune=xscale -Wa,-mcpu=xscale
+-CC = $(CROSS_COMPILE)gcc
++#CC = $(CROSS_COMPILE)gcc
+
+ robostix: robostix.c
+
diff --git a/recipes/robostix/robostix/makefile-rules.patch b/recipes/robostix/robostix/makefile-rules.patch
new file mode 100644
index 0000000000..f00d2884e8
--- /dev/null
+++ b/recipes/robostix/robostix/makefile-rules.patch
@@ -0,0 +1,25 @@
+--- robostix/Rules.mk.orig 2008-03-08 10:36:37.000000000 -0700
++++ robostix/Rules.mk 2008-03-08 10:37:14.000000000 -0700
+@@ -24,21 +24,7 @@
+ vpath %.c ../Common ../Shared
+ vpath %.S ../Common ../Shared
+
+-CFLAGS += -Os \
+- -Wall \
+- -Werror \
+- -Wimplicit \
+- -Wpointer-arith \
+- -Wswitch \
+- -Wredundant-decls \
+- -Wreturn-type \
+- -Wshadow \
+- -Wunused \
+- -Wcast-qual \
+- -Wnested-externs \
+- -Wmissing-prototypes \
+- -Wstrict-prototypes \
+- -Wmissing-declarations
++CFLAGS += -Os
+
+ CPPFLAGS += $(AVR_MCU_FLAGS) -I . -I ../Common -I ../Shared
+ LDFLAGS += $(AVR_MCU_FLAGS) -Wl,-Map,$(basename $@).map